1. #21
    Hi jezhawk.

    I'm still running OS X 10.11.6 (my Mac doesn't support Sierra), but I was able to visit a retailer and perform limited testing on a display model running OS X 10.12.5 and can confirm your observations.

    Unfortunately, I couldn't get past the "App is damaged… " message, even when applying the override solution (I suspect because admin privileges weren't available). I can offer some possible solutions, but I haven't been able to test them.

    As of OS X 10.12, Apple requires users to authorize the use of any application not obtained from the Mac App Store or an identified developer. Apart from the removal of the "Anywhere" option, the official solution is identical to OS X 10.11 (override Gatekeeper).

    When the "App is damaged…" message appears, click the "?" button. At the bottom of the help window, click the link to the override method and follow the instructions.

    Some key points:
    - your user account must have administrator privileges (the account you created when you set up your Mac will have these).
    - locate the Riven Mac Installer using the Finder (do NOT use Launchpad).

    Apart from that, control-click the app, then choose Open from the contextual menu.
    If all goes well, you should get either a message advising that the app is from an unidentified developer or a request for your admin password (or both).

    If you still can't open the installer (the "App is damaged…" message reappears), it's still possible to restore the "Anywhere" option to the Security settings, but hopefully that won't be necessary. I'll provide those details if required.
    Share this post

  2. #22

    Riven X Installation

    I've tried installing Riven X both on my iMac (running OS 10.6.8) and my MacBook Pro (running OS 10.12.6. In both cases, when I try to open the program, I get a message saying it can't be opened. Any ideas as to why, and how I can resolve this issue? Many thanks.
    Share this post

  3. #23
    What do you mean by Riven X? The installer, and ScummVM, is only available for use with the CD & DVD versions of Riven.
    Does the error message occur when trying to use the installer, or after installation, when trying to open Riven in ScummVM?
    What exactly is the message received?
    Share this post

  4. #24

    Riven X

    I'm referring to Riven X, the program that purportedly enables one to run Riven on Macs with intel processors. I have the Riven discs, but that's not the issue. I can't install Riven X in the first place. As I mentioned in my first message, when I attempt to open it after downloading it, I get a message that says the file can't be opened. To be honest, when I fisrt downloaded it, I was expecting to have to install the program like any other; but when I click on the Riven X icon, my Mac just treats it like any other file--one that can't be opened in this case. As these messages probably make clear, I'm not computer expert; I'm just trying to figure out how to get Riven X up and running.
    Share this post

  5. #25
    Don't really know why you're bothering with Riven X... you simply don't need it. My Riven Mac Installer offers a complete package, including a compatible version of ScummVM (which does run Riven on Intel Macs).
    Just download my installer, run it, and you're good to go.
    Note that when you first try to open the installer on OS X 10.12.6, you should get an "App is damaged..." message. This is standard behaviour for Gatekeeper, and nothing to be concerned about. Simply follow the instructions in post #21 above to launch the installer. This issue doesn't apply to OS X 10.6.8.
    Share this post

  6. #26

    Riven Mac Installer

    The reason I'm not using Riven Mac Installer is because I've already tried it and had the exact same experience. When I try to open it, I get the following message: "The application “Riven Mac Installer” can’t be opened" No "the App is damaged," etc., just that. And there's no "?" to click on anywhere, simply an "OK" at the bottom of the window containing the "can't be opened" message.
    Share this post

  7. #27
    Thanks. Now we're getting somewhere. I can help you with the Riven Mac Installer, but unfortunately, Riven X is outside the scope of this thread.
    It's going to be permissions related, but I need details to determine the correct fix.
    It's unusual for Macs to say an app can't be opened without giving a reason. I appreciate you've already answered, but I need you to confirm. Have you reported the full message, and if not, what is the full message (please don't leave anything out)?
    Are you using an account with administrator privileges (the first account you created on your Mac will have these)?
    To eliminate a possibility, please right-click the installer and select 'Show package contents'. Open 'Contents' folder, then 'MacOS' folder. Do you see a grey file named 'applet', or is it plain white?

    Edit: Just a quick follow up question.
    I can understand you getting the app can't be opened message on OS X 10.12.6, but are you saying that the Riven Mac Installer reported the same message on OS X 10.6.8 as well?
    I'm not seeing anything unexpected on either OS X 10.6.8 or OS X 10.11.6 (unfortunately, I can't test OS X 10.12.6), so I'm wondering if I'm misunderstanding you.
    Share this post