Thread: The Crew PC Stability & Crash Issues | Forums

  1. #181

    Current hardware requirement

    The link in first post of this thread is 'not found'.
    I found that current requirements of hardware are described in
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\The Crew (Worldwide)\Support\Readme
    For video card,DX11 and shader model5.0 are reqired.
    GTX260,DX10 and shader model4.0,is no longer available
    Share this post

  2. #182
    t6nu's Avatar Junior Member
    Join Date
    Sep 2016
    Posts
    2

    game crash fix

    i had issues with game crashing right after i upgraded my gpu from amd 6950 to gtx 660ti. so when i turned v-sync off it didnt crash anymore. and after i turned it on it immediately crashed. I uninstall amd drivers with DDU before and cleaned all the temp stuff.

    EDIT: i deleted the my documents file and tried playing with v-sync on and it didnt crash atm. it might still crash on pvp tho. need to give it a try later.
    Share this post

  3. #183
    I've been having random hard crashes with a few soft crashes here and there no matter what i'm doing. Granted, my PC is not exactly powerful (FX4300 @4.5 Ghz, 8 GB DDR3 1600, HD7770) but is enough to run the game at 60 fps in low settings.

    At first i though it was my PC, so i cleaned it but i'm still having the same issue. Just finished the fist New York mission and i'm forced to reset my whole PC.

    I love this game, but it's seriously driving me nuts.
    Share this post

  4. #184

    poor performance

    35-45 fps and lower GTX 970 1920-1080
    Also got i5 4690k 4.3 GHz and 16 gb ram 2400 MHz. Can any1 help me ? Support just ignoring me another week.
    Share this post

  5. #185
    After one week of google, searching forums for solution, writing to support (with they don't answer), updating my programs software and full reinstall of windows, verify game, reinstalling and other methods provided by good people here ( thanks for your words)

    GAME WON'T EVAN START!!!!!!!!!!!!!!!!!! SHAME ON YOU UBISOFT FOR MAKEING GAMES THAT DONT EVAN START, NEVER GONNA BUY GAMES FROM YOU EVER. I WANT MY MONEY BACK!!!!!!!!!!!!!!!!!!!
    Share this post

  6. #186

    Crashing while playing

    I crash all the time. Have done everything this thread has suggested. I have friends that don't crash at all and can play all day. I'm not even sure why I care anymore. Its obvious at this point that there is no fix coming. Ubisoft has moved on to more games that they can sell. Fixing past games doesn't net them money. I'll say this however, there is no way I'm buying Wild Run DLC if the main game wont run for more then 20 minutes. I miss the good ol days when companies focused on making a game that lasted, not making a game they can stack DLC, and Micro-transactions on. For shame.


    My System:

    Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
    16GB DDR4 RAM
    64-bit OS
    GeForce GTX 970 (Driver Version 373.06)
    2TB Hard Drive
    1TB Hard Drive
    OS running on 250GB SSD.

    Temps are all in the Green.
    Share this post

  7. #187

    I face the same prob here too , my Rig handles the game well at 60 fps despite of using ultra settings, but it crashes all of a sudden with no error messages at all, and my pc becomes usable only when I restart it
     1 people found this helpful
    Share this post

  8. #188
    This game is ****ed,it worked fine for me since start and 1 year ago,now i get a stupid crash witch i can only describe as it is,when i play no matter if solo or multiplayer,my image and sound dies and i can only start my pc by stopping it from the PSU and powering back on,game works fine at 60 fps with custom settings...

    FX 8350
    16GB RAM DDR3 1600
    GTX 760 OC MSI edition
    700W gold PSU
    SSD AND HDD ,game is on HDD and its 7 years old,but that doesn't stop me to play games like Wolfenstein the new colossus and the type of crash does not occur with any other ubisoft game but The Crew...
    Share this post

  9. #189
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    20,535
    Hi CrewHunter, please try verifying your files.

    Please contact our Support Team https://support.ubi.com including a DxDiag report and MS info, so we can take a look.

    Thanks
    Share this post