Thread: [EASY FIX] Stutter/Frame Skipping Far Cry 4! | Forums

  1. #31
    Originally Posted by SookMePlooms Go to original post
    Couldn't agree more mwelling12

    It does work for the general stuttering. However this is not a fix. It has a major impact on texture quality, especially if you're capable of running the game with ultra textures. At lower texture settings you might not notice as much of a difference but it's there and some textures look terrible.

    It also doesn't "fix" the random "stalls" when you're moving through the environment at high speeds (at any quality settings). I refuse to call this stuttering as the game engine will just freak out and pause for about a second when it happens. It completely breaks the immersion of the game. I've ended up veering off a cliff or into a tree when the game does this, recovers and your controller/keyboard input suddenly kick in and sends the car/bike off in a random direction.
    After playing a while i see that it is a placebo effect and it does impact a lot the texture quality ..so yes ubisoft we need a patch ASAP
    Share this post

  2. #32
    First thing I'd do is check your VRAM usage - if you're exceeding the card's ram then streaming textures will cause stuttering. Games are pushing much higher VRAM usage of late (one of the reasons I moved from 2gb cards to 4). May not help but it pays to check this first before assuming it something else.
    Share this post

  3. #33

    Hey

    Thanks to the help from DrumPixels - i can finally enjoy the game!
    NOT A SINGLE STUTTER/LAG anymore!



    BUT:
    After i did the changes in the
    "GamerProfile.xml"
    (same directory)



    i7 4770 - GTX 680 - 16GB RAM - Win8
    = Ultra Settings flawless playable without problems.
    Share this post

  4. #34
    Originally Posted by The_Tomcraft Go to original post
    Hey

    Thanks to the help from DrumPixels - i can finally enjoy the game!
    NOT A SINGLE STUTTER/LAG anymore!



    BUT:
    After i did the changes in the
    "GamerProfile.xml"
    (same directory)



    i7 4770 - GTX 680 - 16GB RAM - Win8
    = Ultra Settings flawless playable without problems.
    Enjoy playing low resolution textures then.
    Share this post

  5. #35

    excellent advice

    Hi there thanks for the advice had stuttering problem, did what you said and it's solved my stuttering problem by 99%
    Game runs smooth now very happy

    Excellent advice thank you again...
    Share this post

  6. #36
    Thanks, this made my game actually playable. The game is pretty fun when you can drive without stutter and end up unintentionally driving off a cliff. This does leave you with crappy resolution textures though. This game needs to be patched. Fast.
    Share this post

  7. #37
    How big of a visual impact does this fix have? I notice a lot more texture pop in, and it just doesn't really seem as smooth? Is Ubisoft working on an official fix? The stuttering is too much. I have an i7 4790k and msi twin frozr gtx 980
    Share this post

  8. #38
    F3TiSH's Avatar Junior Member
    Join Date
    Nov 2014
    Posts
    23
    Just imagine how stutter free this game would be if someone found a way to turn off all textures, everything white, 10000fps 0 stutter.

    With mipmap edit changing textures between low and ultra makes basically no difference in how everything looks, only thing that appears on ultra are sun reflections on weapons, rivers etc.So you might as well use low textures without this edit. Wish they focused on this issue instead of adding more fur.
    Share this post

  9. #39
    Originally Posted by drider86 Go to original post
    THIS:

    Set GPUMaxBufferedFrames="0" to GPUMaxBufferedFrames="1"

    Has fixed the game for me. 0 lag and stutering on AMD graphic cards.

    Big Thanks to DragonRR
    No problem but it was actually Patilion who discovered this. Obviously it may not work for everyone but there is no placebo in my case, the game was unplayable with this set to 0 and smooth (no stuttering at least) on ULTRA settings when set to 1. It may have some detrimental impact on something but I havent' actually seen anything wrong. I don't use the mipmap setting as it made no difference on my system.
    Share this post

  10. #40
    nope, doesn't change anything for me either on both of my rigs. 780 ti and 290 setup.

    Still a stutter fest

    Thanks Obamasoft lol
    Share this post