Thread: Important notice : Texture quality | Forums

  1. #11
    Here's the performance/issues I came across and the fix.

    1.) Performance issues, low frame rates, etc. I had this issue, my laptop has both a discrete graphics card (built-in) for web-browsing and another (Nvidia) for gaming (called Optimus technology). By default, it was using my discrete card instead of Nvidia! I can't recall if I went into the NVidia control panel and saw it was already added but to use discrete, or if I right clicked on the icon, properties, and in there changed the graphics processor. Changing it from discrete to NVidia it ran like a champ on max settings and frame rates much improved. But... something else happened... the heat!!!

    2.) After switching to use the Nvidia graphics card, my laptop became about 1 degree from melting it got so hot. I couldn't even touch some parts of my laptop after about 30 minutes. I then went into the NVidia control panel, found the Might Magic X game, and changed the VSynch setting to adaptive. I also changed the framerate maximum (as seen in the post on this) to 40 and now it's much cooler and smoother. I don't know anything about ATI, maybe there's a vsync option in there for you like NVidia has that you can change.
    Share this post

  2. #12

    Black mİnİmap

    Bugged black map
    My automap and the map I bring up when pressing M is all black. The locations on it appear fine. Also the world map looks fine. Any idea on how to fix this... HELP
    Share this post

  3. #13
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Location
    EMEA CRC
    Posts
    20,551
    Hi volkandrst, please open a ticket with Technical Support https://support.ubi.com
    Share this post

  4. #14
    Originally Posted by Marshmillow Go to original post
    Here's the performance/issues I came across and the fix.

    1.) Performance issues, low frame rates, etc. I had this issue, my laptop has both a discrete graphics card (built-in) for web-browsing and another (Nvidia) for gaming (called Optimus technology). By default, it was using my discrete card instead of Nvidia! I can't recall if I went into the NVidia control panel and saw it was already added but to use discrete, or if I right clicked on the icon, properties, and in there changed the graphics processor. Changing it from discrete to NVidia it ran like a champ on max settings and frame rates much improved. But... something else happened... the heat!!!
    Laptops and 3d games go together about as well as oil & water will mix, unfortunately...;) I often wonder if people buy laptops thinking that "they're just like desktops, only smaller and have a battery for portable operation." Because they aren't even close to desktops when it comes to running 3d games (D3d/OpenGL, etc.) Check pretty much any 3d-game forum you please and you'll read lots of posts by people with dual-gpu laptop "solutions" that are having serious problems because of one thing or another. Generally, an AMD or nVidia gpu is paired with an Intel gpu because by itself the Intel gpu really sucks at 3d gaming, and a gpu capable of accelerating 3d briskly enough to enable a playable frame rate is needed. So, you get two of them to keep up with--settings, drivers, etc. Supposedly you use the Intel gpu for purposes of power conservation (battery life), and the AMD/nVidia gpu when you need performance. At least you know you aren't alone, right?...;)

    2.) After switching to use the Nvidia graphics card, my laptop became about 1 degree from melting it got so hot. I couldn't even touch some parts of my laptop after about 30 minutes. I then went into the NVidia control panel, found the Might Magic X game, and changed the VSynch setting to adaptive. I also changed the framerate maximum (as seen in the post on this) to 40 and now it's much cooler and smoother. I don't know anything about ATI, maybe there's a vsync option in there for you like NVidia has that you can change.
    You artificially capped your frame-rate and so the gpu is not running flat out anymore--it's running just fast enough to play the game at what for you is an acceptable frame-rate. So-called "performance" laptops always struggle with heat because the overriding design concern for laptops is power conservation: as in, "How little power can we design it to use so as to make the battery last as long as possible before needing to recharge?" Laptops have very little internally open space (unlike desktops) and so there's no room for components to safely discharge heat internally, and for reasons of the lack of internal space for mounting and & power conservation considerations (again), laptop designers stress the operating limits of the hardware by including as few cooling fans as possible, along with making them as low-power as possible. The result is exactly what you got when you let the nVidia gpu deliver the performance it is capable of. This works in the case of M&MX Legacy because this is really nowhere near being a game that requires a brisk and constantly high frame-rate; for games that do require a high frame-rate to play fluidly you'll find that capping the frame rate will result in noticeably sub-par game play.

    For best results and value: build a desktop for your 3d gameplay and buy a laptop for your portable needs that sips as little power as possible (meaning you won't need a second gpu, etc.) You'll actually save money over the long run and be much happier as a result, imo.
    Share this post