Thread: Can't connect to Ubisoft services / limited mode | Forums

  1. #1
    metalgearso1971's Avatar Senior Member
    Join Date
    Jan 2011
    Posts
    527

    Can't connect to Ubisoft services / limited mode

    I'm just curious if others are also experiencing this right now? I can't connect to the Ubisoft services and get thrown into Limited mode.
    Share this post

  2. #2
    Koopa_the_Ripper's Avatar Member
    Join Date
    Oct 2013
    Posts
    39
    yep same problem for me, i sent a message to ubisoft support but no answer...
    Share this post

  3. #3
    AngelAyla's Avatar Junior Member
    Join Date
    Dec 2010
    Posts
    20
    I can connect on AC3 but not AC4. Been like that for a few hours now.
    Share this post

  4. #4
    metalgearso1971's Avatar Senior Member
    Join Date
    Jan 2011
    Posts
    527
    Great, now even Uplay doesn't work for me anymore...

    Damn it, can't they even make a decent announcement anymore something is wrong?
    Share this post

  5. #5
    metalgearso1971's Avatar Senior Member
    Join Date
    Jan 2011
    Posts
    527
    SP is working again. Not sure what caused those freezes.
    Share this post

  6. #6
    ThisIsBrybry's Avatar Member
    Join Date
    Dec 2012
    Location
    Brilliant, OH
    Posts
    67
    Been stuck in limited mode all day.

    It starts to connect because it pops up that I have a clan invite but then it goes limited.
    Share this post

  7. #7
    gothpunkboy89's Avatar Senior Member
    Join Date
    Dec 2010
    Posts
    1,124
    Last hour been having this issue. Can't get on servers. I've looked pretty much every place I can online (face book, twitter, this website news or support) to see if this is some planned or expected outage. I'd ask support but unless they added a live chat or have a phone number I can call they take so long to replay by the time I get their answer the issue could be gone.
    Share this post

  8. #8
    metalgearso1971's Avatar Senior Member
    Join Date
    Jan 2011
    Posts
    527
    Well, just got the most unhelpful reply ever on their Facebook page: there is nothing wrong, please check your connectivity.

    How about no, Ubi? People actually replied to my post on your Facebook page saying they had the same issue. Friends from England have the issue, and I live in The Netherlands. It is NOT my connection, it is your servers.

    Loads of people complain about this crap going on, so fix it instead of posting automated responses that aren't helpful.
    Share this post

  9. #9
    AngelAyla's Avatar Junior Member
    Join Date
    Dec 2010
    Posts
    20
    Agreed. They seem to prefer shuffling it off to "support" where it gets ignored for days, only to come back with "it's you not us" regardless of how many people write in about it. I live in Canada and having these issues all day so far.
    Share this post

  10. #10
    gothpunkboy89's Avatar Senior Member
    Join Date
    Dec 2010
    Posts
    1,124
    Originally Posted by AngelAyla Go to original post
    Agreed. They seem to prefer shuffling it off to "support" where it gets ignored for days, only to come back with "it's you not us" regardless of how many people write in about it. I live in Canada and having these issues all day so far.
    Its always been that way with ubi sadly. They can make good games. but supporting them is far beyond their ability on the internet side of games. Any time their games have server issues it is never their fault it is always the player's issues. Even though I can and have gone on Black Ops 2, Ghosts, Lost Planet 2&3 and played online with no issue. Yet when it comes to AC 4 to ubi it is my connectivity issue.

    South Eastern USA my location. So obviously this is not a local issue.
    Share this post

Page 1 of 23 12311 ... Last ►►
//Uplay Overlay login for community forums