1. #1

    It won't open

    No matter what i do i can't get the launcher to actually start.
    I've reinstalled this thing 5 times
    every time i tried to run it as admin as well as not as admin
    i look under processess to check if it's running there ~ it only is a couple seconds after i click it, as in i click it to run it, my computer loads for a few seconds, it says "uplay.exe" under services, then uplay.exe closes, and nothing happens.

    The whole reason i installed Uplay is because i just bought a new graphics and with it came FarCry3 Blood Dragon for free. I was planning on playing this but in order for it to work i needed to install it through uplay and yadda yadda.

    The first time i opened Uplay it worked fine, i started installing the game, but then I wanted to test out what my new graphics card could do so i shut down Uplay ( i hit pause on the download first) and then played some other games. After this I tried opening Uplay again and to no luck, i then searched through every help forum i could find and so far nothing i've done has worked so i made my own thread, please help
    Share this post

  2. #2
    Ubi-Lhainiev's Avatar Moderator
    Join Date
    Jul 2012
    Ontario, Canada
    Hi Zp;tel62 -

    Please read the tips found at the beginning of this thread - http://forums.ubi.com/showthread.php...ection-issues?

    If they don't help, create a ticket to Support by clicking on the My Questions link, then Ask a Question tab here: http://support.ubi.com/ They will do some one-on-one troubleshooting with you and resolve the issue.

    Alternatively you may call them. You can find the Support Team in your region here: http://www.ubi.com/US/Support/InternationalSupport.aspx
    Share this post