Thread: Problems with L3 sprint button. | Forums

  1. #1

    Problems with L3 sprint button.

    hey, I wanted to post this kind of thread at the technical issues, but for some reason I cannot post there.

    This problem is getting completly ridicoules. playing the Far Cry 3 story mode on PS3, the L3 sprint button not only does sprinting, but nearly every other function as well. Pressing only the L3 button, I have seen the carachter in the game pick up the camera, throw rocks, use syringes, shoot, switch weapon, like I said, nearly all the other button's functions.

    When I press the L3 button, I want to sprint, nothing more. Most of the time it picks up the camera, which stops the sprinting in it's tracks.

    In a nutshell, The L3 sprint button is malfunctioning only with FarCry 3 (I've tried other games, L3 worked just the way you would expect). I have tried it with both my controllers, and both have this issue, so I am guessing it is not controller-related. It obviously is an issue within FarCry 3 that only I seem to be having, because I have not seen any other people with this issue.
    Please, can someone tell me how I can make this problem dissapear, because it is really getting in the way of enjoying the game.

    Thanks in advance.
    Share this post

  2. #2
    Mr_Shade's Avatar Senior Community Manager
    Join Date
    Nov 2009
    Hi there,

    Have you contacted support directly?

    if not, please do so via
    Share this post

  3. #3
    Hey. Just so you don't feel alone on this issue, I am having the same issue. Tried changing controllers even resetting my PS3. Sometimes it doesn't do it for a long time and then all of a sudden, it'll do it so often. I'm gonna write Ubisoft today. Have you contacted support?
    Share this post

  4. #4
    I'm having the exact same problem Interestingly though, I'm not playing on PS3, but on PC with my PS3 controller. I realize the number of issues that could be causing it on PC, but it seems odd that PS3 would experience it as well. Any way of fixing this would be greatly appreciated.
    Share this post

  5. #5
    so...... its been so long since the game comes out, they still havent managed to solve this problem.
    rip, i even finished this game already, good job ubisoft!
    Share this post

  6. #6
    I had this problem too with my old xbox controller too, somehow the L3 key works on every other games that werent published by Ubisoft, still.
    But when I bought a brand new xbox controller it surprisingly works!
    dont ask me the reason cuz I have no idea but you should get a new xbox controller and maybe save the old one as a spare maybe.
    Share this post