1. #11
    Titler's Avatar Junior Member
    Join Date
    Apr 2003
    It's just started doing this for me too; Missions failing to start at the final loading stage and bouncing back to the title screen. Trying it online, or selecting planes Loadouts are giving a network error however, so I've a suspicion that it's Ubisoft's always on DRM that's become broken. I've tried verifying via Steam, and there's no Repair tool that I can see in uPlay so apart from a reinstall, I've tried everything else.... again though, with so many reports, I'd wager it's the DRM. Shame on you if so Ubi, it literally makes the game unplayable (and an absolute CPU hog, which I suspect is it constantly trying to call home and failing)
    Share this post

  2. #12
    I have the same issues, the first few mission played good, but from the fourth, it started kicking me back to the main menu. Tried searching all over the net, no help yet. UBI SOFT is silent on this matter. I wonder if they know this or not. How to contact the tech people of UBI SOFT, they have to find a fix or refund.
    Share this post

  3. #13

    very good

    Originally Posted by shawadys Go to original post
    I have the same problem, happens very often but i found a way to start the missions.

    In the game's main menu, open 'Online' then open 'Player Match', and wait till it finishes searching (Usually i get 'No Games Found'). Go back and try starting the mission again, and skip the cinematic, Worked for me almost all the time!
    this a way is very OK! i have the same problem...already solution
    Share this post

  4. #14
    I have completed some missions, but difficult to play the game by same problem.
    Share this post

  5. #15
    We all need to thanks to Ubisoft for this bloody game.
    Is not loading at all, only return to game menu and Ubisoft don't do anything about this.
    I want to show them my middle finger.
    THANKS for nothing.
    Share this post

  6. #16
    will ubisoft fix this problem? i just bought it and i cant play it, i think that the game try to load from cloud saved games but cant find it or something like this.
    Share this post

  7. #17
    Wow, that is annoying. Bought the game a few weeks ago and now I wanted to test it..,
    We all know that is has a "great" copy protection but those side effects will scare loyal customers away. Please ensure properly working auth servers 24/7 or respond immediately if users start to complain!
    Share this post

  8. #18
    Dear Ubisoft-Guys,

    this problem is not local any more. Everybody paid for this game, so we can expect it to work.
    PLZ fix this issue or refund us the price of the game!
    Share this post

  9. #19
    OK, here's how I fixed that.
    Launch Uplay, go into top right corner, click on the gear icon. There, check the "Always start Uplay in offline mode". Restart Uplay. Run the game. Everything should be working now.
    Share this post

  10. #20
    I also thought about that and I also disabled the cloud-synchronization for savegames.
    Unfortunately it doesn't work
    Anyone else got ideas?
    Share this post