Hello! I was wondering if one of you kind souls would help me?

It's very strange, but DirectX 11 causes my game to crash when I try to play it with it on.

I have Dual AMD Radeon HD 6990 CrossFireX graphics cards, with CrossFireX currently enabled.

So far I have tried:

Playing without CrossFireX enabled (the game crashed before the main menu appeared)
Playing with updated drivers (DirectX 11 will crash at some point, a few seconds after)

That's about it, really. DirectX 9 works fine.

Extra Information:

DirectX 11 worked before for me when I was disconnected from the Internet, so could this be something to do with uPlay?

Full Specs:

Type                            	Alienware Area-51 ALX
Manufacturer             	Alienware
Operating System	        Windows 7 Home Premium
CPU	                                Intel(R) Core(TM) i7 CPU 960 @ 3.20GHz, 3201 Mhz, 4 Core
Memory	                        6GB RAM
Video Card	                Dual AMD Radeon HD 6990 CrossFireX
Sound Card	                Realtek High Definition Audio (There are AMD ones, not sure why)
Hard Drive	                1.75 TB (1,922,111,107,072 bytes)
Headphones	                Turtle Beach EARFORCE Z1
Mouse	                        Alienware Mouse
Mousepad	                Alienware Mousepad
Keyboard	                        Alienware TactX
Monitor	                        Alienware OptX AW2310 - 23"
I would really appreciate any help as this is such a sexy game and this is the only real downside that I've seen so far.