Thread: Far Cry 3 XP SP3 doesn't work...error 0xc0000142?! | Forums

  1. #31
    Everyone who gets the Application Error 0xc0000142
    After I've stumbled on some guys who were trying to run Far Cry 3 with whine and ubuntu.
    Just download Assassin's Creed III reloaded crack like from gamecopyworld it's the newest crack from ACIII.
    Take the ubiorbitapi_r2_loader.dll from there and copy paste it over the Far Cry 3 reloaded crack.

    Meaning you install the patch 1.01 or just let the game be updated from uplay, then copy AC3(reloaded) ubiorbitapi_r2_loader.dll and FC3(reloaded) FC3.dll, FC3_d3d11.dll, orbit_api, uplay_r1_loader.dll in "C:Program FilesUbisoftFarCry 3bin" folder.
    I'm using the default shortcut from FC3Updater with -offline parameter on XP sp3 32bit(x86) also you might wanna increase the gpu buffer in options it seemed to fix the lag if you have any, I'm using gts 250 1gb, but still get decent fps at max settings on 1440x900.
    Also my saves work, but I get sometimes some crashes when I'm going through the menu too fast, like split second decisions back and worth so it kinda goes freeze, happens maybe once per few hours, might be also memory issue.
    Share this post

  2. #32
    tell if its work i will try later and say does it work
    Share this post

  3. #33
    its work for me i hope ubisoft make fix if they wont me to buy original
    Share this post

  4. #34
    when i double click on the game icon nothing happens
    the game does not start, no errors, nothing happens
    any one knows why?
    Share this post

  5. #35
    Fox , I did everything just like you said , It worked fine for me , but I've got a problem , (somehow It launched one time normally , but atm I'm having "logging in..." problem and it lasts forever )
    I'm using -offline etc but it does not work, what shall I do?
    Share this post

  6. #36
    Originally Posted by d3m0n1c669 Go to original post
    I just registered and read this forum discussing this problem or issue with the game on xp. Now I dont come here to argue but I must point out that yes xp is way out dated but to be more honest over half of the pc user's still use xp. Why because it happens to be the most stable and reliable operating system out side of linux. Win 7 Vista even the new Win 8 is not nearly as good as xp. I must also point out that I to am having this same issue. I just installed the game ran it and was given a error. The game as they said can run on xp but I am unsure if that is true. I am more curious on why the creators of this game did not properly test the game for the pc before releasing it. As for the user that stated to try the ps3 or xbox360 version. Let me tell you something boy first off when a game comes out and the creator states that its for the pc version us pc users go and say great and we buy the game only to find out it has issues. I am not saying that I do not play games on ps or on a console but come on now when you see a good game and it states its for pc and states it supports xp you figure what the hell and you find out differently? Perhaps they did not fully know that it was going to not work on xp but if that be the case then they did not properly test this game like they should have done before releasing it. Only thing I can say right now is this. Maybe the team that created this game should have tested it properly and not half assed it. Truth be told half assing anything will only result in a half assed product. If you are going to do something do it right.

    Ubisoft l-"Lets say that we will deliver the game on three OS systems but we will screw them so that we get MORE money".
    I could swear all these famous game publishers and game developers starting to becoming a nutshell.
    Its a shame that Ubisoft as famous game creators become more like other company's.
    Share this post

  7. #37
    fox829, I can confirm that fix works in XP SP3.
    That said, UBI and developers should not be held to account for any problems caused by hacks.

    ENEMYGATES: just a thought, but are you using the DX11 shortcut instead of DX9? Because DX11 shortcut doesn't seem to work for me either, even in Win7 with AMD+NVidia card. (another DX11 game seems to work so far)
    Share this post

  8. #38
    i dont know if can post a link here , but here it goes for users that are having 0cx0000142 error on windows xp :

    unpack the rar archieve and replace the ubiorbitapi_r2_loader.dll on your bin folder in far cry 3 directory with this one .
    This is a temporary solution until ubisoft release a patch to this issue .
    You wont be able to log in to ubisoft or play multiplayer but you can play game as solo .
    also edit your shortcut from far cry 3 icon on your desktop like this ( and directory where far cry 3 is installed\bin\farcry3.exe" -offline)
    thanks all here that helped in this temporary solution .
    Share this post

  9. #39
    Originally Posted by shavarsh9999 Go to original post
    Fox , I did everything just like you said , It worked fine for me , but I've got a problem , (somehow It launched one time normally , but atm I'm having "logging in..." problem and it lasts forever )
    I'm using -offline etc but it does not work, what shall I do?
    try unistall and install again update to 1.01 and reaplace file ubiorbitapi_r2_loader with as creed III and install uplay if you not
    Share this post

  10. #40
    Thanks for this fix, fox. FC3Updater.exe still crashes for me, but launching from farcry3.exe works perfectly. Hopefully Ubi can release a patch to fix this.
    Share this post