1. #1

    Uplay Can't Connect to Internet

    Every time I try to log in to uplay it says login failed "There seems to be a problem with your internet connect. Please check your settings or switch to offline mode." I'd love to switch to offline mode but this is my first time using uplay and it wont let me do that. I've tried turning off antivirus and firewall and it still doesn't work.
    Share this post

  2. #2
    Okay, reinstalling and resetting the hosts fixed my problem but now I have a new one. When I try to log in, uplay now immediately crashes, I think this has something to do with eh update since I could attempt to log in before, but after the patches can no longer do so.
    Share this post

  3. #3
    Alright, if I disconnect from the internet. Uplay just tells me it cant connect. So I'm thinking Uplay connecting with the internet is causing it to crash.
    Share this post

  4. #4
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Hi, please try opening the following ports;

    Uplay Launcher:
    TCP: 80, 443, 13000, 13005, 13200

    If you are still having issues please contact Technical Support, the link is in my signature.
     1 people found this helpful
    Share this post

  5. #5
    Greetings fellow threaders. I seemed to have fixed this exact problem last night, after angrily working on it for four hours. I have windows 8, and for some reason Uplay would not connect to the internet. I tried deleting the hosts file, I tried opening various ports in my firewall and my router, and I tried to run Uplay without any background programs running. Sadly, none of this worked. But, when I started my computer in Safe mode with networking, Uplay could connect.

    For me at least, it was not a problem with Uplay's servers, but it was the fault of my own programs running in the background. So, if anybody else is getting the error "Uplay cannot connect to the internet..." try this:

    Open the ports TCP: 80, 443, 13000, 13005, 13200, 14000, 14008 in the windows firewall (Find it in control panel)
    Then boot up your windows in safe mode with networking
    Uplay should now be able to connect!
    You only should have to boot up Uplay in safe mode for the first time (so it can update), and then you can run it in normal startup mode.

    Before you get too angry at Ubisoft, please make sure the reason your game doesn't work is not a result of your own doings (i.e. installing Norton). I now happily play AC3 with no trouble.
    Hope this helps!
    Share this post

  6. #6
    Ubi-Lhainiev's Avatar Moderator
    Join Date
    Jul 2012
    Ontario, Canada
    Thank you for this Golax510!
    Share this post

  7. #7

    This connection kills me

    i have some issues with the login of uplay account, i already try everything to make me connect with the server. could you help me ? btw my windows are 10 edition. please send it to my email .

    thanks for your time
    Share this post