Unable to see or use Uplay rewards in Ruse. Gold chip is greyed out in options , unable to upgrade pershing to super, and no d-day map. When I Try to enter uplay beta ( default in ruse) I get the following message. The ubisoft account you entered doesn't exist. Please double check the username and password, then try again: It like Ruse and uplay beta isnt communicating. After the error messange log in with my account information and it brings up my account showing all rewards and stats. Exit out of uplay beta (back to Ruse) and enter uplay beta agian with same error.

Questions are the following 1> Where is the Uplay account information stored with Ruse steam version.

2. Is it possiable to re-link uplay and Ruse.

3. IF 2 is no is there a was to remove and add a uplay aco**** information.

I have tried the few mention steps on the fourms in regards to remove Ruse data files from steam to no effect, really seems like its simply that steam Ruse and uplay arn't linked, even to I can log into uplay and have all my data show up, and the ruse site and have all my stats show up.