1. #1

    Unable to download game information

    Problem Fixed! Check out my post http://forums.ubi.com/showthread.php...me-information

    So Im having the same problem of this guy: http://forums.ubi.com/showthread.php...rmation-Forums
    I payed ACR Gold Edition in Steam, downloaded it installed it etc etc. Launch the game, first message of all Uplay stopped working, I run the program (Uplay) as administrator and then log in. I launch ACR Gold Edition from Steam again (gotta close Uplay for launch...) and then the square... and then the message: Game information is loading... (Le me: Yay!) then: Unable to download game information (Le me: FFUUU) I press the button try again, and try again and try again but nothing happens.

    I Preffer to make a post here in the forum because the guys from the support takes like 2 or 3 days to give you an answer for your problem.
    Share this post

  2. #2
    I have the exact same problem, i already wrote to the support center but the only thing i got is a computer generated response.
    I already saw this thread in different gamer forums but nobody knows the answer.
    So please somebody help, i (and i think i can speak for the guy above) think that the support is not a great help here.
    Share this post

  3. #3
    i have this issue too but with AC2 deluxe bought on steam, and i wanna play the game now! this so disgusting...
    Share this post

  4. #4
    This issue is really annoying because we do not have problems with logging in or sth. like that.
    I already contacted the support and post here what they wrote.
    Share this post

  5. #5
    I posted a ticket at the technical post and they have given me a lot of answers and instructions but nothing have work for me. You should try these maybe works for you and Im making something wrong:

    First Answer:


    I have included some steps below that may help with the issue you are having. In most cases, if uninstalling / reinstalling the game launcher did not work, you may have some corrupted game files within the registry. In most cases we suggest calling in directly for assistance with removing reg keys. Please view and try the steps below in order to get your game up and running.

    Start by using the integrated steam tools to check the game files in case of any issues.

    1. Right Click the game title from within your Steam game library

    2. Choose Properties

    3. Switch to the "Local Files" tab

    4. Select "Verify Integrity of Game Cache"

    5. Select "Defragment Cache Files"

    6. If you still have trouble, delete the local game content and redownload.

    Next, if you have already tried completely deleting your host files, please also use the steps listed within the Microsoft Support article in regards to actually resetting the files. This may be similar to deleting the host files, however the results end result could be slightly different.


    Finally, use the steps below to close any running background processes in case of issues with running programs

    - Open your start menu and look for Run (Win XP), Start search (Win Vista), or Search programs and files (Win 7)
    - Delete anything on the Open line that you'll find there, and type in the word MSCONFIG and press the Enter key to bring up the system configuration utility
    - Look down the list of startup items (not the tab labeled Startup), and choose Selective Startup (if it is not already selected) (If you don't see this, make sure you've clicked on General, near the top of the window)
    - Once you've chosen Selective Startup, uncheck 'Load Startup Items'
    - Once you're done here, click Apply & OK, and let it reboot your computer

    Try running the game again. If the game loads and seems to be working, the problem is most likely related to one or more programs you have scheduled to load with Windows. You can then revert the settings back the way they were, and in a trial and error fashion, disable some programs using the startup tab (in the msconfig utility) to try to find the culprit.

    Second (Here I told them to activate the game for me... and they can't ._.)


    Unfortunately we do not have a way to activate your key for you. Do you have Steam currently installed in the default location onto your computer? I also don't see a mention of redownloading the game. Can you try deleting the local game content through steam and redownload the game? Finally, please also try configuring the following network ports in case the download issue is related to the a restriction on the network.

    ACR Ports:
    UDP: 21200, 7959, 3074

    Uplay Launcher:
    TCP: 80, 443, 13000, 13005, 13200
    Share this post

  6. #6
    Nope nothing of these tips worked for me, why can't they just activate our keys?
    Maybe it is related to the server problems in the past few days?
    Share this post

  7. #7
    D4rkii77 also posted this workaround yesterday, which worked for him (thanks by the way ).

    So I closed it then started Uplay as administrator and the thing ran, then I started my game from Steam Uplay opened then Loading game information but ends with Unable to download game information.

    Well first of all this is a Windows Problem not Ubisoft problem so blame Windows this time xD.

    The problem is Windows don't let Uplay to be launch as administrator from steam so what you have to do is go to your Uplay install directory, then allow users (not only admins) to have a full access to the folder.

    How to do this:
    1.- Open Uplay folder (normally: C/Program Files/Ubisoft/Ubisoft Game Launcher
    2.- Press right click
    3.- Press Properties
    4.- In Properties normally you start at General, switch to Security
    5.- You'll see two screens, one with the users and system and creator owner and other with the permission for the users
    6.- Click edit then it will open a new window
    7.- At the upper screen select your user and at the window below you will see a lot of options checked and unchecked
    8,- Check the option with name Total Control at the allow part then press apply
    9.- Open Steam and launch your game again
    10.- The game should load and then ask for your cd key, enter your cd key and play !
    Could you let me know if it works for you too?
    Share this post

  8. #8
    Korchaa, that worked for me!
    Thanks a lot!
    Share this post

  9. #9
    You are awesome! I've been tring to get it to work for five days. Took me a awhile to find the right folder but thanks!!!!
    Share this post

  10. #10
    Heh Ty ^^!
    Share this post