1. #1

    cant log on to UPlay

    I can't log into UPlay with the same username and password that I used to login into the account that I am presently using to post here. I've tried a couple of times to change my password and no matter what I try it won't accept the new password in the UPlay login window. It will only accept it on the website. Do I need to change my UPlay version somehow? I got the version that came with the CD of the settlers game.
    Share this post

  2. #2
    I'm having the same problem, and getting really pissed at the way Ubisoft treats its users! The problems is on their server and not with you! In the future I would recommend not buying products from this company until they get there act together!
    Share this post

  3. #3
    looks like the same old problem coming around again.
    Share this post

  4. #4
    Same happening here... but the thing is I turned on my PS3 and it played perfect no log in bull **** but jus crappy graphics..... but my steam copy is not getting passed the log in screen jus get a dumb incorrect user name message..... On another note has anyone been able to play Sabotage mode on PC? i can never find an active server on pc and this is by far the best game mode.... i can only play this mode on my ps3 way suks eggssss!!
    Share this post

  5. #5
    i also cant log on to uplay! but there is a strange error message: "your username or password is incorrect. please try again.". i tried the same log in data as on uplay in the browser and here in the forum. whats wrong?
    Share this post

  6. #6
    Same here!! Can not log in uplay, even though username and password are perfectly functional. This company is a piece of crap, no support whatsoever, barely accessible website and I am not even able to use products I have payed for! FIX IT - NOW
    Share this post

  7. #7
    Can't login too
    Share this post

  8. #8
    sings_in_tune's Avatar Moderator
    Join Date
    Mar 2011
    Southern Ontario, ...................... Canada
    I haven't been able to log into the forums for the last hour or two.

    Cannot log in to the game. Says username or password is incorrect.
    Share this post

  9. #9

    UPlay password not working

    Im also having trouble. im able to log in here to ubisofts forums and pages, and my account. But when i try to log in to my UPlay account after launching my game through Steam, it says username or password is incorrect each time.

    Ive reset the password a few times now, and it lets me use the new reset passwords to get on here each time, but wont let me log in to play the games purchased for my account.
    Share this post

  10. #10
    Same here cant they just warn a person that its offline i cant even access there website. what a bunch of bull
    Share this post