Thread: BSOD when exiting to Desktop | Forums

  1. #1

    BSOD when exiting to Desktop

    That's basically it. Game runs beautifully, no issues whatsoever, but when I try to exit the game, I get a BSOD. Someone suggested trying to exit via Task Manager. Game shut down without a problem but UPlayBrowser was still running. When I tried to shut that down, BSOD.

    I cannot get an answer from anyone on how to resolve this matter. As a result, I haven't played it since for fear of damaging something on my system. And to think I was worried about buying Ghost Recon Future Soldier.

    Oh, btw, that one doesn't run at all thanks to the Yeti Fatal Error thing.

    Can Ubisoft ever release anything that works right? I won't make that mistake again. But for now, fix my games because I'm **** close to selling both of them and letting someone else deal with the mess.
    Share this post

  2. #2
    Green.Hornet's Avatar Member
    Join Date
    Jan 2011
    Hello BuzzardBee... first-of-all, you need to calm down and get a grip. It's not the end of the world. Why would you assume that it's Ubisoft's fault... generally, a Blue Screen of Death (BOSD) is hardware and/or driver related which would indicate that the problem is on your PC end. Your particular problem/issue is most likely happening because of hardware and/or software conflicts, and without any type of adequate/detailed information it's impossible to troubleshoot. If you can provide any detailed/adequate information (as you have provided none at all) here on this thread (see, I will be glad to assist.

    Good luck.
    Share this post

  3. #3
    Okay, let's try this again. And yes, I am calm. Believe me. You haven't seen me when I've lost it.

    Anyway, forget the above. I know for certain it was the UPlayBrowser that was giving me the BSOD. So now we have UPlay 2.0. It loads up, shows me my copies of Ghost Recon Future Soldier AND Splinter Cell Conviction. Curiously enough, it doesn't show me my copy of Assassin's Creed Revelations, but that's another matter.

    So, I take my chances and try to run SCC. It seems about to make my day when I see "Game running..." Only it's not running. So I go about checking things. First I remember that I don't have the game disc loaded so I do that. Then I check my settings for SCC and found that I'd left it to Run as Administrator since that was the advice I'd been given before.

    Guess what? I unticked that, clicked on the UPlay launcher, it still only shows GRFS and SCC but that's fine. Click on SCC and the game actually ran. I played a Deniable Ops mission and then exited to Windows Desktop -- no BSOD.

    So yeah, my conclusion still remains it was the fault of the old UPlay Launcher. Anyway, case solved. My beloved SCC once again runs and now doesn't give me a BSOD on exit any more! Yay!
    Share this post