I have bought ACII today and spent hours on fixing this problem.
When I installed game, there was an error about Ubisoft Game Launcher. That was not installed on program files folder and when I tried to install it manually, it didn't worked.
I tried to install UbisoftGameLauncherInstaller.exe on my DVD's support folder. But there was nothing I clicked next button.
So after my tryings, i tried to remove registry keys and edit hosts file. And surprisingly it worked. Now I share my solution, maybe someone who have the same problem with me can fix this infernal problem.

Run regedit.exe
delete launcher and ubisoft game launcher folders


edit file which has a name "hosts" with notepad and delete lines which is containing ubisoft or ubi phrases
and save it

delete C:\Program Files\Ubisoft\Ubisoft Game Launcher

folder and remove ubisoft game launcher

and download it and install

This link didn't open for the first time. But when I edited hosts file it worked

If you have any problems after installing launcher. Edit hosts file again and try to run it again.

I hope this works. I tried to help people who is becoming mad because of this problem.

And sorry for my bad english