Thread: How to create server game from my home | Forums

  1. #1

    How to create server game from my home

    Hello i try from google but i can't find any thing from there.I like to know how i can create my own server from my pc to play with friend's.I dont know what i have to do or if i can fix some things to my router.Please can you help me?

    Thank you and i am sorry for my bad English...
    Share this post

  2. #2
    There are two ways to run a server,
    #1 a “in-Game” Server
    1. Start FC2 / Log in / select “Ranked Match” or “player Match” (player match = No Punkbuster)
    2. Select “Create Match” (bottom line)
    3. Select Game type/ map Cycle / etc, click on items for options
    4. Be sure to select server options from the Advanced Options tab
    5. Fire up server and see if a friend can join NOTE…you must be IN the server you create, or the server will shut down when you exit.
    6. If the server isn’t visible be sure ports 9000 to 9060 are forwarded in your router.
    7. If the server still isn’t available, you may neen a static IP, check with your provider to see if one is available.

    #2 a Server using a “Server Extender” (allows server to run even if you aren’t “in Game”) "Dedicated Server"
    See Tutorial on this Here :,340.0.html

    Good Luck … Rhett
    Share this post

  3. #3
    I have windiws xp and i fix the forwarded ports in my router and still i can't create server my ping is 9999..I call my provider and they say to me that i must pay to get static IP.
    \Maybe is another way to create server?
    Thank you...
    Share this post

  4. #4
    The only way I know of for you to run a server w/o a static would be using Tunngle or something like that, Static IP's usually aren't to expensive,and your server will pop right up. Ping will depend on your internet speed and location to other players.
    Share this post

  5. #5
    You also need to turn on UPnP in your router's settings. We were having a heck of time trying to set a server up as well tonight.

    Things I did to make it work.
    1. Open ports 9000-9004
    2 Turn on UPnP

    I also made myself DMZ initially which did not help at all by itself.
    Share this post