Thread: 1.3 patch won't install - message says HOMM6 "not yet installed" | Forums

  1. #1

    1.3 patch won't install - message says HOMM6 "not yet installed"

    Won't work through the downloaded .exe file or through running gu.exe. Either way, I get the message that HOMM6 is "not yet installed."

    Two other odd details. First, when I run gu.exe, the message that comes up as it's trying to install relates to the "closed public beta." Second, I think the patch downloaded through Steam on the first day it was released. Nonetheless, the game won't update.

    Can anyone help me?
    Share this post

  2. #2
    Bueller? Bueller?
    Share this post

  3. #3
    This is clearly a weird Steam problem. Have tried contacting Steam support.
    Share this post

  4. #4
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Hi, yes please contact Steam support or you can contact Technical Support through the link in my signature.
    Share this post

  5. #5
    I guess you have both beta client and heroes 6 game installed. Maybe you should try to uninstall beta client and main game ad delete folders created by game (install folder, profiles ect)
    after that please try to install game - it should work fine
    Share this post