1. #1

    Can anybody help with my connection to game servers?

    Every time i enter a game, I get this message saying Connection failure, Lost connection to the game server returning to lobby. It's so annoying because it happens on EVERY map i try to play. It usually does this when the map is loading, it then freezes, the display that shows all of the players names on squad 1 and 2 are refreshing as well, and finally i get a black background with a message that says Connection failure, Lost connection to the game server returning to lobby. Is there something wrong with my internet or something? I restarted my internet and even my computer and i still get the same message. Do i need to patch my game or something? Please help..
    Share this post

  2. #2
    Apheration's Avatar Junior Member
    Join Date
    Oct 2008
    The first thing I would do is disable any firewall software and if using a router, hook up your computer directly to the modem and try again. If you're still getting the error, at least you know it's not a port issue.
    Share this post

  3. #3
    First, where are you connecting from? Expect to be disconnected if you aren't in North America and your provider doesn't give you realistic ping/latency value.

    Second, as sort of suggested, look at your firewall software and ensure that you have it in gaming mode, if it offers one. If that doesn't work, then try shutting it off the firewall software, as long as you are behind a NAT-ing router. If it still doesn't work, then check your router port security settings and ensure that you have the appropriate game ports open. Only as a last resort, would I recommend that you connect your PC directly to the Net without some type of filtering device or software. The risk is too great just to play a game.

    Would love to tell you specifics on how to check your firewall software or network hardware mode and port settings, but with no info provided, I can only tell you to Google for the same.

    Good luck!
    Share this post

  4. #4
    Don't know if you are still in the beta, but I'm experiencing the same problem. If you figured out how to solve it could you tell me! It would help alot!
    Share this post