Hey all,

I purchased the game a few days ago and am getting the black screen on startup. I have read through every forum I could find but none of those fixes are working; does anyone have any new information to share? I emailed tech support but they are very slow to respond.

I am running an Asus G73 laptop
Windows 7 Home Premium 64-bit
Intel i7 Q720 1.60ghz
ATI Mobility Radeon HD 5800 Series 1GB RAM (I think exact model is 5870)

Detailed Description:
I downloaded the game through Steam - everything went smoothly with dl and installation. When I start the launcher I get the window about copying the Key to verify the game. When I hit "Play" in the uplay launcher the game opens with the animated Ubisoft logo which transforms in to the Might and Magic logo. When that fades I get a black screen with the game cursor. At this point I'm stuck and have to ctrl+alt+delete to get back out of it. I've tried it many times and have tried the various recent fixes I've found in the forums. I've also verified my graphics card driver is updated. What a bummer to buy a game and not be able to play at all