1. #1

    D3D9 Caps Error

    D3D9 error pops up as soon as I hit Play Now ****on and tells me to look in a folder. When I look in the folder, it comes up with a bunch of "Passed" things until I notice that a few say "Failed". How do I fixed the failed ones?
    Share this post

  2. #2
    Hey sirgell,

    Please try changing your game resolution settings.

    Try to run the game in Windowed mode, at low quality and in 1024 x 768. You can change the settings manually by going to Local Disk C\Ubisoft\GRO-Live\NCSA-Live and change the following:

    Windowed= 1 for windowed, 0 for full screen DisplayWidth= 1024 Display Height= 768 ShadowMapSize=3 PostProcess=3 ShaderVersion=3 RenderBloom=0 RenderDOF=0 ParticleFX=1 TextureSize=2 DrawingDistance=1 VolumetricShadow=0 MotionBlur=0 LodQuality=2 ShdLodQuality=3 Windowed= DisplayRefresh=0
    Share this post

  3. #3
    i have to the problem but by me comes this The system does not meet the D3D9 caps requiremets. See YetiCapsError.txt for more information and then this Destroyed TArray without calling Deinit. This is a memory leak! File: d:\Build\GRO\live-dev\Yeti\engine\SDK\ARR_TArry.h Line 48 Break Now? please help i use a Shader 2.0 graphiccard :O
    Share this post

  4. #4

    same problem

    i have been having the same issue with exact same error message. is there a solution or is it my computer?
    Share this post

  5. #5
    UbiSusie's Avatar Game Master
    Join Date
    Jun 2011
    in Sanity, Quadrant ZRT731
    Hey guys, if you are having any issues installing or running the game, make sure you put in a support ticket regarding it so we can help you get this issues solved and get you in game and playing! When you submit your ticket, please include your DxDiag. If you are unsure of how to retrieve this information, please follow the instructions below: 1. From Windows, click Start->Run
    2. In the Open: box, Type DXDIAG
    3. Click the save ****on to save the file as a text file in your Desktop.
    4. Click the back ****on in this browser and attach the file at the bottom of the page.

    You can find the link for support under my signature. Thanks!
    Share this post

  6. #6
    Is there a download to make my system meet the D3D9 caps requirements?
    Share this post

  7. #7
    Cortexian's Avatar Volunteer Moderator
    Join Date
    Apr 2012
    Calgary AB, Canada

    If you're receiving that error it's probably because your graphics card doesn't support DirectX9 or newer.

    Try installing this though:
    Share this post

  8. #8
    What does **** mean?
    Share this post

  9. #9
    I downloaded the link but it still pops up saying the system does not meet the D3D9 requirements what do I do now?
    Share this post

  10. #10
    it didnt work can i do
    Share this post