Thread: AcrSP.exe has stopped working | Forums

  1. #1
    gvazdas's Avatar Junior Member
    Join Date
    Apr 2012

    AcrSP.exe has stopped working

    Hello everyone, thank you for trying to help me if you will.
    On Christmas, my brother gifted me Asassin's Creed Revelations (SE). I've been playing it ever since, however I have jumped back into it a few days ago.
    I haven't finished the story yet, so I decided to continue playing it. I played the game for about 2 days with no problems or crashing whatsoever, however today my game crashed with the error 'acrsp.exe has stopped working'. I relogged into the game and played for about an hour or so when it crashed again with the same error. I entered the game again, but it crashed minutes after I started playing it. I restated it and it happened again with no change of how long I could play it. I had not updated ACR or the game launcher.
    I've read numerous threads with all kinds of advice, like changing the CPU threading, re-installing my game with Ubisoft Launcher and so on, but nothing worked.
    I was so desperate I decided to re-install my drivers (10 out of 10 cases updating or re-installing my drivers didn't work), which, DUN DUN DUNNNN - didn't work. I'm extremely desperate to play this game...
    A quick summary of my computer (I cannot attach my dxdiag.txt for some reason):
    Windows 7 Ultimate (64 Bit)
    AMD Athlon 64 X2 Dual Core Processor 6000+ ~3,1 GHz
    4096MB (4GB) of RAM
    NVIDIA GeForce 550 Ti (Integrated) 2783MB Memory.
    GPU supports and uses DirectX 11.
    512 kb/s DL Internet Speed.

    Oh, almost forgot. Here is the 'more information' tab of the crash report:
    Problem signature:
    Problem Event Name: APPCRASH
    Application Name: ACRSP.exe
    Application Version:
    Application Timestamp: 4f3a78e5
    Fault Module Name: ACRSP.exe
    Fault Module Version:
    Fault Module Timestamp: 4f3a78e5
    Exception Code: c0000005
    Exception Offset: 00f1c1b2
    OS Version: 6.1.7600.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Any advice would be much, MUCH appreciated. Thank you for the help!
    I played the multiplayer and that didn't crash. I had about 3 matches or so without any problems so it has to be a problem with the Story mode.
    Share this post

  2. #2
    zevran09's Avatar Junior Member
    Join Date
    Apr 2012
    I got exactly the same problem and still dont know how to fix it. I've tried everything: all drivers update, defragmentation, memtests(nothing wrong with memory), system file scan and fix but game still pops up this pretty little window "ACRSP.exe has stopped working bla bla bla..." I also got Win 7 Ultimate(64 bit) , 8GB Ram, geforce8600gt(this old junk still alive). I've played till 7th seq (Desmond Journey crashed) now it dont want to work anymore. I'd prefer to avoid disck formating so I hope somebody will find any solution. I looked over Internet and found out that many players( not only ACR but BF3 and ME3) got same probs, same error messages like this one on Win7 64bit, but other players dont have probs with it wtf? Please, if there is some Goddess of Internet help us, we need this game!
    Share this post

  3. #3
    gvazdas's Avatar Junior Member
    Join Date
    Apr 2012
    Just a note: I tried playing the game again the next day and the crash was a little delayed - I could play about 30 minutes until it crashed. After that happened I launched the Story mode and it crashed minutes later. I'll try it the next day again to see if it happens.
    Share this post

  4. #4
    Black_Widow9's Avatar Community Representative
    Join Date
    Apr 2007
    Please contact Ubisoft Support by following the link in my signature.
    Share this post