Thread: Heroes VI Launcher & Multiplayer Connection Issues | Forums

  1. #81
    Originally Posted by Zugrov Go to original post
    Hi there,

    I also made my experience with UPlay and Conflux the last days. Me and a few friends are playing PC games quite some time now. No one of us likes restrictive DRM due to several problems in the past but Heroes VI really excels here. Here's what happened: since I'm the IT guy in our little gaming club I sometimes have the "pleasure" to assist the others in my spare time when it comes to tech issues. Two of them bought Heroes VI via Steam and while I was thinking about it too one of them - let's call him R. - started to spit curses into the microphone. So I looked after the problem with him. The Conflux screen showed a "connecting" message but that was all that happened. To keep it short we tried everything we found on the web, the UBI-forums and even more. That includes checking every single point of the opening post.

    Nothing worked. The next day I tried to find out more and in the German forums was a single discussion concerning the exact issue as described. The user had an account problem. He couldn't connect to Conflux with his own account (no error message, just "connecting" screen). That connection issue also appeared on other PCs he tried to log in. Also, other accounts worked on that PC well with Heroes VI. Now guess what...

    On my advice my two fellas temporarily changed their passwords and swapped their accounts. Now it worked on PC 1 and PC 2 --> "connecting"

    I tried to convince R. to open a ticket but I failed here since he was too upset (I don't want to repeat all that bad words here). What really bothers me is the fact that we found this out in quite a short time. So this specific issue MUST be known by UBI too. Obviously the same people in charge of this playing-online-all-the-time-to-use-all-game-features-crap do not have the guts to admit: "Yes, if you experience that problem you got an account issue. Just write a ticket and we care about it, send an knew install-key to you or whatever it takes". Instead of this the officials keep officially quiet about it. I didn't buy several games in the last time due to things like this including Mass Effect 3, Anno 2070 and now Heroes VI. In our gaming club we agreed not to buy games anymore if they include these "we don't like our customers"-features.

    As usual first level support and moderators have to take all the beatings. I am aware of the fact that this won't be read by the responsible people. Those suit wearing, overpayed folks with several pounds of hair gel on their heads who studied either business-[placeholder] or some marketing stuff trying to tell US that everything they do is for our best. Ok clichés...but

    I am a really patient and good willing customer. But I can't take this any longer. For the big publishers it is time to bring the garbage out.

    So i fixed the conflux problem on my friends account. i had him install uplay here then had him log into it then start up might and magic 6, it might ask you to close it, do this. then restart might and magic with uplay closed and it will pop up and ask for your cd-key. then he logged into conflux perfectly.
    Share this post

  2. #82
    Thanks Ginobino2009,i will try that.

    Update: Well, it worked! It REALLY makes me wonder though why they haven't made a sticky thread about
    the issue OR mention it on their FAQ section OR fix the problem with the incremental game patches they have
    released for the game.Weird...
    Share this post

  3. #83


    i bought this heroes 6 on steam in 2011 and played the game for a couple of months
    and now i tried to play the again and i got this
    please help out
    Share this post

  4. #84
    Originally Posted by ginobino2009 Go to original post
    So i fixed the conflux problem on my friends account. i had him install uplay here then had him log into it then start up might and magic 6, it might ask you to close it, do this. then restart might and magic with uplay closed and it will pop up and ask for your cd-key. then he logged into conflux perfectly.
    ok I didn't understand what you meant really..
    I uninstalled uplay then reinstalled with the link you posted, then i tried to start the game but if uplay is running, i cant connect it says. and if i turn off uplay right before the game starts the connecting just keeps rolling..

    please help me out on this as it seems it works
    Share this post

  5. #85
    I can not connect to uplay... I have no problem with the game updating but it won't let me play online .... so I can not get to my save game which is very painful
    Share this post

  6. #86

    Unable to connect to Uplay

    If you want to play the game offline, create a shortcut on your desktop then:

    -Right click on the shortcut
    -Click on properties
    -Look for the field "Target", where the path name is written
    -At the end of the path name type in: /offline

    Worked for me. All online features are disabled though...
    Share this post

  7. #87
    I've had this problem too. I have continuously contacted both steam support and ubisoft support; steam support will not refund me for this broken game, and ubisoft support just keeps sending me copy+paste threads from the forums, which I have tried all of already.

    Ubisoft tech support usually takes 2-4 days to respond to ANYTHING as well, and then will close your tech support thread if you don't respond for 24 hours. I have wasted over 12 hours trying to get this game to connect to conflux so I can experience the dynasty content and use cloud saves, but nothing has worked.

    Do yourself a favor and never buy a Ubisoft game again. EVER.
    Share this post

  8. #88

    Look, apparently certain countries have problems with connecting to conflux. If you browse the forum, you'll find a suggestion which ports to open ( Also when you contact the support it's useless just to say "heya guys the game ain't workin' u sukk and I won't buy another thing from Ubi ever again".

    Please when contacting support always, not just for Ubisoft games, always include as much data as you can collect, that means apart the country you live in, your system specs (you can get that by running dxdiag).
    Share this post

  9. #89
    Did anyone ever find a solution to the "I can play fine with strangers but it won't let me play with my friends"-problem? My boyfriend bought me this game do we could play against each other, but we just get "Connection timeout". We can both connect to all other games perfectly, but not at the same time, and not to to each others games. I just find it weird. Why should his games be the only ones I can't connect to?
    I'm not really expecting a solution to this problem. I'd appreciate if someone could explain it to me, though. I just don't understand why it's like this, and that bothers me. (Of course, should someone actually happen to have a solution, I certainly won't turn it down).

    The single player is fun too, I guess, but playing with my boyfriend was what I was looking forward to the most, so this makes me a sad panda. Oh well.
    Share this post

  10. #90
    I have similar problem.
    I live in China and try to play with my friend from Russia (both games on both PC are Russian releases from Buka).
    I can connect to Confux (although starting from patch 1.5 or 1.7 the connection to Confux now for me takes much more time then earlier (5-10 seconds - before, now maybe 30-60 seconds).
    But when we try to start the mutiplayer - we get the "Connection timeout" message.
    Anybody have an idea how to deal with it?
    Share this post