1. #231
    What a joke bought this game last year and still unable to download it. Never got an email response. Would be nice to be able to play the game at some point.
    Share this post

  2. #232
    I recently purchased the Tom Clancy's H.A.W.X.® 2 - All in one Pack , however none of the planes, skins , or the scenarios are visible to me. can anyone help me ?
    Share this post

  3. #233
    I purchased this game during the steam sale.. I played last night with only minor problems with keybindings. Started playing today and it kicked me, telling me i dont have an internet connection.. It kicked me out of a single player game for internet connection.. My internet is fine and im really upset about this.. I just paid money for a game and now i can't play even the single player part of the game because the game thinks i dont have internet.. I have good enough internet to live stream league of legends, counter strike, planetside 2, but not good enough to play thesingle player part of hawx 2. Ive been all over the forums and it seems many others are having the same problem.
    Share this post

  4. #234
    I just purchased this game in the bundle pack, downloaded it, installed it - everything went fine, then when I played it, the first mission loads and starts out with taking off - everything works at this point and continues to work up until the point when the helicopter gets shot down - it says to hit the space bar to enter precision mode, I do, and it zooms in with the different labelled keys (i.e. spacebar - fire missile) - it says the direction keys for aiming, with the t key for exiting that mode - it is at this point that the keys stop working - the plane apparently continues flying, but none of the keys work - the flashing target indicators go by under the plane - so the game hasn't froze up, just the keys won't work. I have tried several different key bindings with no difference in results - and when I hit the F1 key that is labeled "default" it does nothing, so now I don't know if it's because of my chosen key bindings. I tried uninstalling the game and reinstalling it with no result either. Please, if anyone can help with this.................
    Share this post

  5. #235

    Playable But

    I just got the game a couple of days ago and beat the story line....I leveled up but nothing that is supposed to unlock at my lever actually unlocked...still stuck with the 2 intro planes and no weapon packs....I'm level 17
    Share this post

  6. #236
    i have the same problem with my AC3 the hidden secrets pack , I already paid for the game and after 5 try it wont let me download the DLC anymore this is the message the I get "Too many download attempts: 5. You were allowed to download only 5 times."
    if anyone have any solution please let me know
    Share this post

  7. #237
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Hi LtAngels, please open a ticket with Technical Support, the link is in my signature.
    Share this post