1. #1
    Microsoft Visual C++

    Runtime Error

    Program: C:\Program Files\Ubisoft\The Settlers 7 - ...

    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information


    The installation of this game went smoothly, yet when the autopatch reaches 100% this error pops up, please help me with this problem
    Share this post

  2. #2
    Microsoft Visual C++

    Runtime Error

    Program: C:\Program Files\Ubisoft\The Settlers 7 - ...

    This application has requested the Runtime to terminate it in an unusual way.
    Please contact the application's support team for more information


    The installation of this game went smoothly, yet when the autopatch reaches 100% this error pops up, please help me with this problem
    Share this post

  3. #3
    this happened to me as well reinstalled 3times bt still cant play
    Share this post

  4. #4
    Queen8's Avatar Junior Member
    Join Date
    Aug 2010
    Posts
    10
    Have you recently installed any New Google Toolbars?

    If you have then try uninstalling them and loading the game again.
    Share this post

  5. #5
    Yes, I get exactly the same error. According to the file name shown (when you click on the Advanced button), it seems to want to download version 1.11. It almost gets to the end of the download (over 1gb), then takes ages to download the last 6kb or so, then shows the error mentioned above.

    And no, I don't have any Google toolbars installed, especially not recently.

    Any ideas?
    Share this post

  6. #6
    I've figured it out I was having this problem too.

    This worked for me, I don't know if it will for everyone. But while it's autopatching, just close the autopatch window by pressing the X or the Quit button, doesn't matter. Then a message will come up saying something like "you can't play until you download the patch" and it will give you a download link for the patch. Once you've downloaded and installed that, try running the game again.

    The same autopatch window as before will pop up again, but just close it - the game should run now, after a few requests bubbles asking you to allow or deny the game access to internet etc.

    I hope this works for you ^^
    Share this post