Thread: IDirect3DDevice9::Present() | Forums

  1. #11
    I had this same problem, but I have nvidia 6600GT video card and the problem stopped when I rolled back to the 84.21 nvidia drivers. I also play it on low settings and so far I have played OK.

    Hopefully they will patch the game so we can play on higher settings with more current drivers.
    Share this post

  2. #12
    BTOG46's Avatar Global Moderator
    Join Date
    Mar 2006
    <BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by SageShadowbane:
    yes 6.9 I believe </div></BLOCKQUOTE>

    I`ve found that the 6.9 driver causes problems in other games too, when I updated to it, games that had always run without problems became buggy and one, Age of Mythology wouldn`t even run, and that has run no problems on several different sytems for me.
    I rolled back to the previous driver and everything ran perfectly again, judging by the posts in other game forums 6.9 must be bugged. <div class="ev_tpc_signature">

    Official Whisky taster and Herald to the Mighty Alderbranch Administrator "The clues are out there.....S.N.A.F.U."
    Share this post

  3. #13
    I get a similar error with a GeForce 6800E. The game tries to load the level after the Cyclops attacks. Then it get a "DirectX 9 error in Device", while crashing to a 16 color 640x480 desktop. I have DX 9.0c installed. Rebooting restore functionality to my computer, but the game runs horribly. I think it is some kind of program error because the game runs fine and fast then seems to hang. Stutters rather than just low framerates.

    Patch please.
    Share this post

  4. #14
    Yeap... i get this same error, after 2mins of playing chap 1.

    Anyone got a link for ATI 6.8 drivers or lower?

    PS. I got x800XL 256mb
    Share this post

  5. #15
    <BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Crashlight:
    I get a similar error with a GeForce 6800E.


    I strongly suggest all Geforce 6800 owner to go and check this topic :


    Share this post

  6. #16
    I am consistently able to cause this error with the memory not read. I can do this especially when I first load the game. If I try do a lot of differnt things in the game at once (attack, cast magic, open doors, etc), and get the game to start accessing the hard disk heavily, it will freeze, loop sound then crash with this error. If I spread around the loading it does not crash as easily.

    This is playing the SP retail version (non Steam).
    AMD 64 3200+
    Abit KV8 Maxx
    ATI 850xt
    1gb ram
    Raided WD Raptors (disk defragged)
    catalyst 6.9
    latest Oct directx
    Have tried all differnt settings for video card and in game. As long as I can get heavy disk access, it will crash.
    I loaded HL2 Eposide 1 to see if it was my comp, and that plays pretty smooth with my setup, was not able to get it to crash.
    Share this post

  7. #17
    I get the same error time and time again, with all settings at low. My systemis:

    AMD 64 3200
    ATI Radeon x800 256
    1gb RAM
    catalyst 6.9
    latest direct x
    Share this post

  8. #18
    Think i figured a work around: I turned all settings to low, and I turned OFF the HDR. Turning OFF the HDR really seems to be the key.
    Share this post

  9. #19
    ARG, THIS is the error I am getting now.
    I just reinstalled the game due to a whole bunch of other problems, and I figured doing a clean reinstall would maybe fix it..but it turns out, it just created more problems, I can't even start the game now because of this guys are luck you even get to change your graphics settings, I can't even get into the game now.

    EDIT: I also should mention that once I got this error, my monitor said "Signal not found" or whatever it's little error thing says when the graphics goes off..and ..well the only way to fix it is to restart the computer.
    Share this post

  10. #20
    Suffering from excatly the same problem.
    Can't even get passed the first quest.

    Powercolor Radeon X850XL PE, 256MB RAM
    P4 Prescott 3GHz
    1GB Corsair Dual Channel DDR Ram
    Omega drivers, Ati Tray Tools (newest), DX9c
    Windows XP pro SP2
    Sound Max integrated soundcard
    Retail, DVD, Collectors Edition, non-steam, singleplayer -version
    50GB+ free HD space, Defraged after install.

    I run HL2 and all sorts of mods for it with no problem. BF2142 and Oblivion too.

    It's strange to have so many problems with a game that's built on a finished and superb game engine. It's ok to have some bugs here and there ,it's normal, but at this scale, not beeing able to play the game at all is unacceptable! I was looking forward to this, it's an awsome game don't get me wrong, but please finish it first! I feel sorry for those people with limited or no internet connection who can't get their hands on the "patch", if/when it comes. They just wasted 50 bucks on a shiney box.
    Share this post