1. #1
    Hi all,
    if you're getting the ominous "There's a problem with Settlers 7" message when linking the game to your facebook account, then please try this link instead of the one provided in-game.
    It should allow you to generate the authorisation code that you have to enter in the Contacts->Facebook menu.

    Should you give it a try - please let me know if this works out for you!
    Share this post

  2. #2
    Tried it! Worked fine! Thanks very much, been struggling with that one for months
    Share this post

  3. #3
    Thanks... worked like a charm. I reckon it had something to do with account privacy settings on Facebook?

    Thanks for the good link. Might want to add it in-game since not everyone is smart enough to search forums?
    Share this post

  4. #4
    Thanks, I glossed over this as it's been so long since a new sticky post. This solution works fine here

    Edit: Perhaps add this to the General Discussion too? Give it more exposure to people seeking information on the feature.
    Share this post

  5. #5
    Worked for mee 2 thanks
    Share this post

  6. #6
    Thank you worked for me too, just spotted this thread now !
    Share this post

  7. #7
    Not works for me
    Share this post

  8. #8
    sings_in_tune's Avatar Moderator
    Join Date
    Mar 2011
    Southern Ontario, ...................... Canada
    The link above worked for me at one time. Then at some point my account became unlinked from facebook. Neither of the links works for me now.
    Share this post

  9. #9
    why does the Link ingame and the link here to facebook not working ?
    Share this post

  10. #10

    It doesn't work for me either. It says: "An error occured. Try again later."
    Share this post