1. #11
    Mittelwaechter's Avatar Senior Member
    Join Date
    Mar 2005
    Location
    Wherever I go there I am.
    Posts
    1,378
    Please try to play the intro movies with your windows media player.

    ...\Ubisoft\SilentHunterIII\data\Movies\Intro

    Do they run?

    Install this driver for your graphics card:
    http://www.nvidia.com/object/winvist...8.24_whql.html

    And you are probably low on RAM for playing with Vista.
    RAM is extremely cheap these days...

    Did you (Could you) switch Turbo Cache of at your Nvidia Control Panel?
    Share this post

  2. #12
    I put xp in and it works great. I was really getting tired of dealing with vista anyway.

    Thanks for all your help!
    Share this post

  3. #13
    If you were running the game with 4xFSAA it may cause a complete blank screen, that's what happened with me. For some reason, 2x, 8x, and 16xFSAA all run fine.....4xFSAA made the screen blank.
    Share this post

  4. #14

    what worked for me

    I just got this working and thought Id share, mostly bc a lot of the solutions that worked for others did not work for me (like XP compat, or win7 compat)

    I had to modify sh3.exe and sh3_g.exe the following way (using the win trouble shooter failed)
    - change compat to Vista SP 2
    - change for all users
    - unclick run in 640x480
    - oddly, make sure "disable fullscreen optimizations" is unchecked
    Share this post

  5. #15
    Yooperbacker's Avatar Moderator
    Join Date
    Jan 2005
    Location
    Upper Peninsula of Michigan
    Posts
    3,928
    Thanks for passing along a fix that worked for you. Hope it helps others.
    Share this post