1. #101
    Hi Kibbles,
    Try the Myst V installer from the link in my sig. I haven't tested on Mountain Lion since I don't have Myst V any more but it ought to still work.

    (If you do prefer the Terminal method, the version of JAD that Heimdall linked to at the start of this topic is a PowerPC-only one and won't run on Lion or later. You'll need to download the Intel version from here, or use some other java decompiler.)

    [edit] Sorry, scratch all that. Myst V itself is PowerPC only and won't run on Lion or later. You'll have to play it on Windows or an older Mac OS X system.
    Share this post

  2. #102
    Originally Posted by Gannet7 Go to original post

    [edit] Sorry, scratch all that. Myst V itself is PowerPC only and won't run on Lion or later. You'll have to play it on Windows or an older Mac OS X system.
    So there's no workaround at all? Nuts. Oh well, I can still play 2 through 4.
    Share this post

  3. #103
    So how come there are ways to play all the other Myst games on Mountain Lion? I just finished 4, and can still run Riven and Exile too. RealMyst no longer works on OSX 10.8, but I don't get why 5 doesn't run. Ubisoft released a Myst V patch specifically for Intel users. What gives?
    Share this post

  4. #104
    Sorry for the double-post, but Myst V installs fine. I've installed and reinstalled it plenty of times. I've used the installer patcher and whatnot; and that all works. If that works, why doesn't the actual game run? How can you install a game and still not have it run? That just confuses me.
    Share this post

  5. #105
    Hi. Thanks for the good info on this thread. I do understand that the installation method presented here is for the DVD version of Myst V. However, I've been trying to use it (the Terminal method) to install M5EOA from the 3 CD version (branded as PC only). Installation proceeds smoothly, but with some errors. The error log indicates that the correct file could not be found for either disk2 or disk3, even though disk2 and disk3 were swapped in and searched when the install called for them. When I try to run the M5EOA application, it gives the error message, "You can't open the application, Myst V End of Ages, because it may be damaged or incomplete." I suspect that this may have something to do with modifying the file, PureJavaFileServiceImpl.jad, and changing the "String as" area to somehow recognize the files on disk2 and disk3. Unfortunately, I don't know how to do this (or even if I'm on the right path). If someone could help, that would be greatly appreciated. Even if it's just to explain why it can't be done with the 3 CD version. Thanks.
    Share this post

  6. #106
    Hi rfrgs800
    I'm sure we can solve this one way or another. Could you post your .jar file so I can download it and take a look at it?
    Also a list of files on the disk (just the top level) might be helpful, along with the name of the disk.

    @Kibbles: Ubisoft's patch merely allowed the java-based installer to work on Intel machines where it previously wouldn't, even under Rosetta. The game itself was unchanged and remained PPC-only but it did work under Rosetta at the time. Only when 10.7 came out was Rosetta dropped, leaving us with no way to run PPC software anymore.
    I had a brief attempt at getting realMyst running under cider at one point but didn't pursue it very far. The same could be tried for Myst V but I'll have to leave that to someone else. Cyan supposedly has plans to re-release realMyst, Riven and Myst V for OS X at some point but there's no official word on that yet.
    Share this post

  7. #107
    Hi Gannet7,
    Thanks for the reply.
    I guess you're referring to the setup.jar file from the Myst5 CD. Unfortunately, I don't have permission to post attachments here. Is there another way?
    Regarding the disk name and top level list of files:
    CD1 name: Myst V EOA
    Files: Autorun.inf, eoa.exe, media.inf, MystV.exe, setup (folder), setup.jar, setupwin32.exe, support (folder)
    CD2 name: disk2
    Files: Autorun.inf, media.inf, MystV.exe, setup (folder), support (folder)
    CD3 name: disk3
    Files: Autorun.inf, media.inf, MystV.exe, setup (folder), support (folder)
    Share this post

  8. #108
    Great, I'll also want the three .exe files on CD1. If you have a Dropbox account you can just put the files in there and create a public link to them, or if you click "See all" in my sig you can find my email address.
    Share this post

  9. #109
    " Quick question: Have you tried using my installer from here? I expect it will need a little modification to work with the CD set but if you haven't already tried it it would be worth a shot." ..Gannet7

    The above quote I've pasted from your private email to me. The link, "here", probably doesn't work in my paste, but it is Gannet7's Myst V Installer Patcher.
    I thought I'd tried all of the installer/patchers, and really, I didn't think it would work, but I'd try it just to cover all the bases. IT WORKED PERFECTLY! Now I feel like an idiot, but thanks so much for your help.
    Here are a few comments I have from my install:
    1). I'm running Snow Leopard on a MacBook Air, and using a USB DVD/CD-RW drive.
    2). When the install called for disk2 and disk3, I had to eject CD1 from Finder, insert CD2, then Browse for disk2 to Mac HD/Volumes/disk2. (Likewise for disk3.)
    3). When the install finished, I clicked Finish. However, Decompressing Sounds was still working for another 5 to 10 minutes, so you have to wait for that to finish before trying to run the game.
    4). I run the game from the default install location, Applications/Myst V End of Ages.
    So thanks again. Your help on this problem is really awesome!
    Share this post

  10. #110
    Awesome, great to hear it worked! I was kinda hoping it would work because after looking at the files that you sent I couldn't see that it should be working any differently from the DVD.
    Regarding point #2, I remember working out how to tell the installer the names of the other disks when I was working on Myst IV but unfortunately I don't remember how and no longer have those files. I'll have to see if I can work it out again...
    Share this post