1. #1
    For those X 52 mavens: in the profile editor the little 3d models no longer appear. I am using Vista 32, and have loaded the latest driver from Saitek. Many thanks
    Share this post

  2. #2
    For those X 52 mavens: in the profile editor the little 3d models no longer appear. I am using Vista 32, and have loaded the latest driver from Saitek. Many thanks
    Share this post

  3. #3
    I had something similar going on with my X52. Though I still prefer xp. So they recommended a newer beta driver.

    Give them a try if you wish.

    32 bit software link:

    ftp://ftp.saitek.com/pub/softw...Software_6_6_2_0.exe

    64 bit software link

    ftp://ftp.saitek.com/pub/softw...Software_6_6_2_0.exe
    Share this post

  4. #4
    <BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Ed6269:
    ... and have loaded the latest driver from Saitek. </div></BLOCKQUOTE>

    There is the reason. The newer version of the Saitek software no longer shows the 3D model of the controller.
    Share this post

  5. #5
    <BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by dirkpit7:
    <BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by Ed6269:
    ... and have loaded the latest driver from Saitek. </div></BLOCKQUOTE>

    There is the reason. The newer version of the Saitek software no longer shows the 3D model of the controller. </div></BLOCKQUOTE>

    The newer official drivers, but the new beta does have 3d controller views. The reason the official vista drivers don't have 3d is because the 3d part relied on DirectX 9c's directinput. Vista did not have this feature so they had to remove it until they came up with a solution in these new beta drivers and software.
    Share this post

  6. #6
    Thanks for the fixes, which worked; I have my 3D view. However, the new profiles I make and save cannot be loaded into the x52. It seems like it's saving the file into a format my X 52 cannot use. I am NOT using the pro version. Are the drivers the same?
    Share this post

  7. #7
    You must make sure you have updated both the drivers and the profile software. The newer software uses a .pr0 file for profiles, the old software used .dat. If your profiles are .dat you will need to remake them.
    Share this post

  8. #8
    Great, that worked, thanks.
    Why did I bother contacting their customer support. You guys probably know more than they do anyhow. Thanks for being so timely.
    Share this post