1. #11
    pennygod's Avatar Ubisoft Support Staff NCSA
    Join Date
    Oct 2008
    Hey savagegod

    The applications that I see that might cause an issue is the ffdshow app and possibly Nero 7. ffdshow is for decoding and encoding video and audio formats so that you can image them onto the hard drive. Try uninstalling these and see if the game launches.

    Also try updating the firmware for the DVD drive. Sometimes the older firmware for DVD drives with burning capability can conflict with copy protection software.
    Share this post

  2. #12

    Bad Boys II

    Hey Guys i have this game "Bad Boys II" installed in my computer but it says "Please insert the correct CD-ROM, select OK and restart application". I use windows 7 to run this game. Please help me to get this game working.
    Share this post

  3. #13

    [QUOTE=mike0c;2733963]Have got the PC DVD-ROM but I get the following message when I

    Originally Posted by mike0c Go to original post
    Have got the PC DVD-ROM but I get the following message when I try and run the game:

    'Please insert the correct CD-ROM, select OK and restart application'

    Not sure what to do to be honest?

    Return the game?
    sir plz tell me a method to start the game so i can avoid this error
    Share this post

  4. #14
    pennygod's Avatar Ubisoft Support Staff NCSA
    Join Date
    Oct 2008
    Hi hassan439

    Most of the times when these errors crop up is because of virtual drive software conflicting with the copy protection for the game. These include Alcohol 120, Daemonware, Power ISO, and Magic ISO among others. These are just the more popular ones. You will want to uninstall any virtual drive software to fix this issue.

    Also it can be a background process that is causing an issue with the copy protection. You will want to put your system into a selective startup.

    To put your machine into a selective startup, on your keyboard press the
    Windows key + R at the same time to bring up the Run command. Delete
    anything on the Open line that you'll find there, and type in the word
    MSCONFIG. Click on OK, and that will bring up a program called the
    System Configuration Utility.

    Look down the list of startup items (not the tab labeled Startup), and
    choose Selective Startup (if it is not already selected). If you don't
    see this, make sure you've clicked on General, near the top of the
    window. Once you've chosen Selective Startup, uncheck 'Load Startup
    Items', and leave "Load system services and Use original boot
    checked. Once you're done here, click OK, and let it reboot your computer.

    Your Windows environment may look different and you may get an error
    relating to your sound device not working (ignore this for now). Try
    running the game again. If the game loads and seems to be working, the
    problem is most likely related to one or more programs you have scheduled
    to load with Windows. You can then revert the settings back the way they
    were, and in a trial and error fashion, disable some programs using
    the startup tab (in the msconfig utility) to try to find the culprit.
    Share this post

  5. #15
    i know this is a very old post but i am getting the same problem...im trying to run Might and Magic 9 with powerISO but it says please insert BLAH BLAH and so on...I'v tried doing what you said pennygod but it didn't work...a friend on steam told me to get the nocd crack but i havn't found anything useful...would somebody be able to either help me with a direct fix answer/suggestions or a link to working nocd
    Share this post

  6. #16
    pennygod's Avatar Ubisoft Support Staff NCSA
    Join Date
    Oct 2008
    Hey sporerule

    The "Please Insert Correct Disk" error is a copy protection error. You will need to make sure that any ISO program is completely uninstalled from your computer for this will trigger the copy protection error.
    Share this post

  7. #17
    Sometimes this error even crops up because your type of DVD drive is not good in reading SECUROM kind of discs. I had this problem with my last two drives, which were always unable to read SECUROM/STARFORCE protected discs. Don't know which types are good and which types aren't for those discs though Seems like a matter of luck.
    Share this post

  8. #18
    hi guys i dont know what it is but my assasins creed works without a cd for sometime (then it crashes with cd or without the cd) i have instaled it on windows 7 64.

    thans if you can tell me whats wrong if not thanks for trying
    Share this post

  9. #19

    My 1st Victory in Battle is dedicated to you my friend

    Originally Posted by videogames10 Go to original post
    I had the same problem/error when I tried to play Command & Conquer: The First Decade on my Vista PC (worked just fine with XP). I'll post the procedure I used to alleviate the problem below. This may also work with your BIA game...

    For those of you who are trying to run The First Decade on a Windows Vista machine and are having trouble starting a few of the games from the TFD game menu (i.e. "please insert the correct CD/DVD error message", etc.), try the following, which worked for me:

    (I'll use Tiberian Sun as an example)

    Click start > computer

    Right-click on the C: drive icon and select the Explore option

    Click Program Files > EA Games (not the Electronic Arts folder should there be one) > Command & Conquer The First Decade > Command & Conquer Tiberian Sun > SUN

    Right-click on the application file called "Game" (should be the 4,568 KB file)

    Choose Send To Desktop (create shortcut)

    Now return to the desktop and right-click on the Tiberian Sun icon you just created

    Select Properties > Compatibility and check the box that says Run This Program in Compatibility Mode For: and choose Windows 98 / Windows ME from the drop-down box (note: use the Windows 95 option if 98/ME doesn't work for you). Click Apply

    Now click on the Security tab and select Edit. Check the box that allows Full Control of the program for each of the users listed in the box. Click Apply > OK. I suppose you could also choose to run the program as the administrator and not concern yourself with this step.

    Keep in mind that you still won't be able to launch the game from the TFD menu, so use the individual desktop icon you just created and make sure the TFD DVD is in the drive. Repeat this procedure for any of the other games that will not launch from the TFD game menu. You may also need to experiment with the operating systems you choose to use with each game when using the compatibility feature (i. e. Red Alert and Tiberian Sun will probably work best with Windows 95 or Windows 98/ME. Generals and Zero Hour may prefer Windows XP-SP2 or 98/ME)

    Note: A few of the games (the original C&C, The first Red Alert, Renegade, etc.) should still launch from the TFD menu. However, Tiberian Sun, Red Alert II, Yuri's Revenge, Generals and Zero Hour are the games that will need to be started via their own desktop icons as outlined in the procedure above.
    My 1st Victory in Battle is dedicated to you my friend
    Share this post

  10. #20

    It didn't work for me :(

    So, I had the same problem trying to open this The Sims 2 my friend gave me (it's a cd-rom copy of the original), and he also gave me the expansion packs (all copies). It worked on his pc, but it gives me this message on mine >
    I tried everything, even the Daemon tool lite (which I don't even know how that helps at all)....nothing works.

    Please someone help!!!
    Share this post