1. #1
    Have got the PC DVD-ROM but I get the following message when I try and run the game:

    'Please insert the correct CD-ROM, select OK and restart application'

    Not sure what to do to be honest?

    Return the game?
    Share this post

  2. #2
    Theres a patch coming Early this week which will fix that should fix that. In the mean time you could (ugg i hate suggesting this...**** you gearbox...i feel like a pirate...argg me maties) google for a nocd crack.
    Share this post

  3. #3
    Thanks for that.

    Managed to locate a no cd patch, it was shark infested waters allright! Needed some digging.

    Share this post

  4. #4
    Mike0c I've got the same prob as u. Is there any possiblity that u could tell us were u located the no cd patch.THX
    Share this post

  5. #5
    I had the same problem/error when I tried to play Command & Conquer: The First Decade on my Vista PC (worked just fine with XP). I'll post the procedure I used to alleviate the problem below. This may also work with your BIA game...

    For those of you who are trying to run The First Decade on a Windows Vista machine and are having trouble starting a few of the games from the TFD game menu (i.e. "please insert the correct CD/DVD error message", etc.), try the following, which worked for me:

    (I'll use Tiberian Sun as an example)

    Click start > computer

    Right-click on the C: drive icon and select the Explore option

    Click Program Files > EA Games (not the Electronic Arts folder should there be one) > Command & Conquer The First Decade > Command & Conquer Tiberian Sun > SUN

    Right-click on the application file called "Game" (should be the 4,568 KB file)

    Choose Send To Desktop (create shortcut)

    Now return to the desktop and right-click on the Tiberian Sun icon you just created

    Select Properties > Compatibility and check the box that says Run This Program in Compatibility Mode For: and choose Windows 98 / Windows ME from the drop-down box (note: use the Windows 95 option if 98/ME doesn't work for you). Click Apply

    Now click on the Security tab and select Edit. Check the box that allows Full Control of the program for each of the users listed in the box. Click Apply > OK. I suppose you could also choose to run the program as the administrator and not concern yourself with this step.

    Keep in mind that you still won't be able to launch the game from the TFD menu, so use the individual desktop icon you just created and make sure the TFD DVD is in the drive. Repeat this procedure for any of the other games that will not launch from the TFD game menu. You may also need to experiment with the operating systems you choose to use with each game when using the compatibility feature (i. e. Red Alert and Tiberian Sun will probably work best with Windows 95 or Windows 98/ME. Generals and Zero Hour may prefer Windows XP-SP2 or 98/ME)

    Note: A few of the games (the original C&C, The first Red Alert, Renegade, etc.) should still launch from the TFD menu. However, Tiberian Sun, Red Alert II, Yuri's Revenge, Generals and Zero Hour are the games that will need to be started via their own desktop icons as outlined in the procedure above.
    Share this post

  6. #6
    ^ In a nutshell, just find the game launch file in the BIA game folder on your C: drive - it'll be an application file. Right-click this file and place a shortcut on your desktop. Now, right-click on the launch icon you just created for your desktop and use the OS compatibility feature. Try using the XP SP2 option first before you experiment with the others. Now, right-click on the launch icon and select "Run as Administrator".
    Share this post

  7. #7
    videogames10 ... BEST HELP IVE FOUND AFTER HOURS OF SEARCHING a big THANK YOU to you!!!!
    Share this post

  8. #8
    well i agree i have actually been looking off and on for months on ways to get it to work and until i found this post i couldnt figure it out.
    now i have them all working EXCEPT for Generals and Zero Hour. i have tried every compatibility setting and even tried running it in admin and without admin on each setting and cant get it to work. im still getting "plz enter CD-ROM/DVD and restart blah blah blah" anyone know y its still happening?
    Share this post

  9. #9
    pennygod's Avatar Ubisoft Support Staff NCSA
    Join Date
    Oct 2008
    Hey savagegod

    Most of the times when these errors crop up is because of virtual drive software conflicting with the copy protection for the game. These include Alcohol 120, Daemonware, Power ISO, and Magic ISO among others. These are just the more popular ones. You will want to uninstall any virtual drive software to fix this issue.

    Also it can be a background process that is causing an issue with the copy protection. You will want to put your system into a selective startup.

    To put your machine into a selective startup, on your keyboard press the
    Windows key + R at the same time to bring up the Run command. Delete
    anything on the Open line that you'll find there, and type in the word
    MSCONFIG. Click on OK, and that will bring up a program called the
    System Configuration Utility.

    Look down the list of startup items (not the tab labeled Startup), and
    choose Selective Startup (if it is not already selected). If you don't
    see this, make sure you've clicked on General, near the top of the
    window. Once you've chosen Selective Startup, uncheck 'Load Startup
    Items', and leave "Load system services and Use original boot
    checked. Once you're done here, click OK, and let it reboot your computer.

    Your Windows environment may look different and you may get an error
    relating to your sound device not working (ignore this for now). Try
    running the game again. If the game loads and seems to be working, the
    problem is most likely related to one or more programs you have scheduled
    to load with Windows. You can then revert the settings back the way they
    were, and in a trial and error fashion, disable some programs using
    the startup tab (in the msconfig utility) to try to find the culprit.
    Share this post

  10. #10
    well i tried that and i still can't get it working i removed MagicISo, Magicdisc, Daemon tools lite. not working,
    tried goin thru the MSconfig and used Selective start up without loading startup items. and still not working. still get that annoying *DING* Please insert the correct CD-Rom and Restart Application. any other ideas? here's a list of my programs on my computer atm

    Adobe AIR, adobe flash player 10 activeX, Adobe reader9.3.1,
    ATI catalyst install manager,
    BFBad company 2,
    Boarderlands, C
    oD World at war and modern warfar 2,
    Command and Conquer 3 and First decade and C&C4,
    Doom 3,
    IGN Download manger 2.3.9,
    Ea Download manager UI,
    Epson printer software and Scan,
    Fear2 project origin, Farcry 1 and 2,
    ffdshow (dont know wut that is even),
    Fraps, gamespy arcade, Garena, Half-life 2, Homeworks starter editions, Impulse,
    LG ODD auto firmware update, Logmein hamachi, Mcafee security center,
    Medal of honor Airborne and allied assault and breakthrough and speahead and pacific assault,
    Microsoft.NET framework,
    Games for windows - LIVE,
    Games for windows - LIVE Redistributable, Microsoft Office Powerpoint Viewer 2007,
    Microsoft Silverlight,
    Microsoft Sync Framework runtime(and services) Native v1.0 (86x), MS Visual C++ 2005 redistributable (x2?) and ATL update kb973923 - x86,
    MS visual C++ 2008 Redistributable-x86 9.0.21022 and 9.0.210.. (2 periods cuz i cant see the last 2 numbers)and 9.0.307.. and 9.0.307, MSXML 4.0SP2(KB936181) and SP2 (kb941833)and SP 2 (kb954430) and SP2 (Kb973688),
    Nero 7 essentials,
    Nvidia Physx (i dont have Nvidia card, im using ATI),
    Painkiller, PowerDVD, Punkbuster Services, R.U.S.E. Beta,
    Realtek high definition audio driver and 8169 8168 8101e 8102e Ethernet Driver,
    Return to castle wolfenstein,
    Roxio Easy Media Creator 9 Suite, SIW Version 2009.10.22,
    Source SDK Base
    Spelling Dictionies Support for Adobe Ready 9, Starcraft and starcraft 2 Beta,
    Superantispyware free,
    Teamspeak 3 Client,
    Battle for middle-earth II,
    Ventrilo client,
    Warcraft III,
    Windows 7 upgrade advisor, Windows Live essentials,
    Windows live sign-in assistant,
    Windows Live Upload Tool, WinRAR archiver, Wolfenstein (the new one)
    is there a chance it could have something to do with all those diffent Microsft application versions? dont want to delete them and end up screwing all my stuff up lol
    Share this post