Thread: User ID Not Registered | Forums

  1. #1
    Maybe I'm missing something here. I signed up for an account where it says "Register" on the main page of I attempt to log in under the muliplayer section, it tells me "user ID not registered."

    Am I just dumb for thinking that coming here and clicking "Register" means I'm registered? Is there some other registration that needs to take place? I do have the latest patch and PunkBuster; all that stuff that I apparently needed to use the multiplayer section. Hmmm...

    Can anyone offer any help, please?
    Share this post

  2. #2
    So... Can I assume that after 173 views and 3 days, nobody knows the answer? Ok, I guess that's what I'm assuming then. Thanks anyway.
    Share this post

  3. #3
    You must create a user account
    Share this post

  4. #4
    You mean that's not what clicking "register" and signing up DID? Then how do I create a user account if not by using the link which seems to be there for creating user accounts?
    Share this post

  5. #5
    I have the same problem and have received absolutely no help from UBI. Seems like once they have your money they don't give a $hit if you get what you pay for or not.
    Share this post

  6. #6
    yea same here.
    Tried making a new id but still nothing...
    Share this post

  7. #7
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Hi guys, please contact technical support, the link is in my signature.
    Share this post

  8. #8

    I have the same problem since March.
    I tried creating and using another account but that didn't work. Then I contacted the Ubi's technical support but it was completely useless — all they told me was that this thing is caused by the incompatibility between RvS and Windows 7 without even trying to tell how the game had been working flawlessly for several months before that.

    Is there any solution to this problem?
    Share this post

  9. #9

    A possible solution

    I've had the same problem and there seems to be no logical explanation. But the solution I found with some help from my friend, was to just create a new uplay account and try with that. Same problem? Create a new account! Same problem again? Another account.. Untill you find an account that works. Yep it's completely unlogical and extremely buggy, but only thing that worked for me.

    Good luck
    Share this post

  10. #10
    ?!??!??? Since when was the r6 legacy forum the place to post when you can't figure out how to registerdur??
    Share this post