Thread: ubisoft game launcher error: error code 2 | Forums

  1. #11
    Originally Posted by king_sapu Go to original post
    i have a problem and i can't find anywhere what to do...
    when i install acr and try to play it i get error code 2 and i tried every thing they said but it doesn't help...
    i think the problem is that i just can't get the game launcher because it doesn't appear in my ubisoft folder. even if i try to download a seperate gamelauncherinstaller than it just stops installing...
    please help me i can't play any game of ubisoft: acr, driver san fransisco, heroes of might and magic 6!
    I had the exact same problem on windows vista home premium 64 bit

    go to windows buton on the bottom left on your task bar on the desktop

    Click Run...

    type in regedit and click ok

    go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Ubisoft

    and delete the entire folders called Launcher and Ubisoft game launcher

    Then run UbisoftGameLauncher Installer.exe and it won't disappear mid install this time, then the game will run without error code 2
    Share this post

  2. #12
    Originally Posted by Ubi-Mush Go to original post
    To resolve this issue, you will need to manually install or reinstall the GameLauncher software, which handles the online authentication in the game. Please note that this software MUST be installed to play the game, and cannot be uninstalled or disabled.

    1. First, you will need to uninstall the "Ubisoft Game Launcher" software from the 'Add/Remove Programs' (Windows XP) / 'Installed Programs' (Windows Vista and 7) icon in your computer's control panel. It's possible that the "Ubisoft Game Launcher" software will not be listed if you have already uninstalled it, or the game. If so, you can skip this step.

    2. After uninstalling the software, you will need to manually delete any leftover files in the C:\Program Files\Ubisoft\Ubisoft Game Launcher (32-bit versions of Windows) or C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher (64-bit versions of Windows). Please do not skip this step, it is very important. If this folder does not exist, please go to the next step.

    3. Reinstall the GameLauncher software from:
    this does not work for me
    Share this post

  3. #13
    I have recently had a catastrophic hard drive failure and have had to replace it. Last time I reformatted I got this Code 2 launcher error and this solution worked for me. This time however it does not. Now I also have Assassins Creed 1 and 2 installed, also UBI Soft. Is it possible they are causing me issues? I will uninstall them and retry, in the mean time if there are any other suggestions I will gladly try them.
    Btw I'm running windows xp on an AS Rock 2.8 mother board, dual core, with an NVIDEA 9800gt video card.
    Share this post

  4. #14
    pennygod's Avatar Ubisoft Support Staff NCSA
    Join Date
    Oct 2008
    Hello rbnSn1p3r

    If you continue to get the Error Code 1 or 2 after reinstalling the Game Launcher software there may be a registry key issue.

    What you will need to do is go through the steps of uninstalling the Game Launcher again. Once this is done you will need to run a registry cleaner to clean out any dead registry keys. Then try and reinstall the Game Launcher software from the link.
    Share this post

  5. #15
    I've just reformatted so is a registry key issue likely and if so then what is a good registry cleaner?
    Share this post

  6. #16
    i still have this prop get black screen for few seconds and quit cant fix it i dont know the reson
    Share this post

  7. #17

    when i start tomclancy splintercell conviction,ubisoft game launcher error code 2.

    error code 2 is coming plz help
    Share this post

  8. #18
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Originally Posted by vikramvivek Go to original post
    error code 2 is coming plz help
    Please see here
    Share this post

  9. #19
    when the download finish i open it and then i cant log in why??
    Share this post

  10. #20
    Ok, i had this same issue and i tried all the solutions i found on the various forums, including reinstalling the game, cleaning the registry and deleting/cleaning the windows host file. None of them worked, so I investigated myself. I looked at the logs of the 'Ubisoft Game Launcher' and found the next line:

    'Resolve failed, IP address to is not valid.'

    So what is going on, does this webaddress not exist?
    To solve this I looked up the webaddress on ''.
    This will give you a list of IP addresses that correspond to this webaddress depending on what country you are in.
    At the time I did this, for following locations, there was no IP address resolved for '':

    * Padova, Italy: Unknown host:
    * Amsterdam, Netherlands: Unknown host:
    * Groningen, Netherlands: Unknown host:
    * Antwerp, Belgium: Unknown host:
    * Dublin, Ireland: Unknown host:

    Since I live in Belgium it now makes perfect sence. This hostname is apparently not know by the DNS servers in my location. Luckily this is easily fixed.
    I added next line to my windows host file:


    This maps the IP address '' to the webaddress ''. I got the ip address from the results of ''. This is the address that DNS servers in Germany direct to for this webaddress. You can choose the one that is closest to your location.
    Hopefully this can help other people with the same problem.

    Share this post