Thread: H6 release v : no-disc error at launch | Forums

  1. #1
    Error on launch: "No disc in tray" ?

    Each time I try launching the game from Steam, I access the Ubisoft launcher just fine. Then when I click PLAY and attempt to launch the game itself, I get a black screen before any splash screens, and hear an error sound.

    Nothing happens (can't minimize) so I ctrl+alt+del out to get to my task manager, and notice a new window.

    An error window pops up informing me that there is no disc in the tray. I can Cancel, Try Again, or Continue.

    I bought the game through Steam, and thus do not own a disc.

    None of the buttons do anything - the window just comes back. The only way to get rid of the window, is to use the task manager to End Task for the game itself.

    I've been looking around for people with the same problem and haven't found any, and so I post here.

    I know the game just unlocked on Steam (for my region at least) an hour ago, but I'd really like to know what I can do to play the game I purchased.

    On the chance that it pertains, I run:
    Windows 7 64-bit
    AMD quad core (II X4 620)
    RAM: 4GB
    ATI Radeon HD 4870

    Share this post

  2. #2
    I've tried re-installing the game, and still I have this error.

    The full error message:

    "Might & Magic Heroes VI.exe - No Disk

    There is no disk in the drive. Please insert a disk into drive \Device\Harddisk1\DR1."

    Is anyone else experiencing this? Any ideas on how to fix it?

    I submitted a ticket to support, and all they told me to do was to uninstall the game, and that they don't have any "disc checks" for this game. Yet obviously they do, cause I'm getting one?

    Any help would be much appreciated, I'd really like to play this game.
    Share this post

  3. #3
    Sorceresss's Avatar Senior Member
    Join Date
    Jan 2006
    One workaround trick which had success for a few people is to insert any disk in your drive.
    Then, when the error pop-up appears, you click "continue" or "retry" or "ignore" up to a dozen times.
    During the Beta, this summer, this trick worked for a few gamers.
    Share this post

  4. #4
    Thanks Sorceresss. I gave this a shot, but was unsuccessful.

    I did find some other beta suggestions for running Daemon Tools so I did that.

    I managed to run the game (although the splash screens each took about a minute and a half to load from one to the next which was odd). Unfortunately, After the first demon fight in the campaign my screen became a series of dark stripes, and my PC restarted on it's own.

    Thank you for replying though, I really appreciate it.
    Share this post

  5. #5
    I have experienced a similar error to yours.
    I've bought the fisic version of the game, with both expansions.
    It opens the laucher, install and plays the two first games with no problems, but, when I try to install the "Tribes of the East" expansion, it says:

    "Please, insert another DVD to run HoMMV: Tribes of the East installer"

    But the disc is already inserted!
    Also, I have registered the game to re-download it through internet, but they keep asking me for a credit card number or a "purchasing code", and I dont know what this later is
    (possible because I have'nt bought it through internet).
    Have anyone experienced the same issue?

    Thanks in advance.

    PS: Please, warn me if this is not the right place to post this. I have experienced a dozens of computer issues during my life, but this is the first time I post one. ^^
    Share this post

  6. #6
    Ubi-MoshiMoshi's Avatar Community Representative
    Join Date
    Nov 2011
    Hi Rrlke, I suggest opening a ticket with our Technical Support team so they can troubleshoot this with you, the link is in my signature.
    Share this post

  7. #7


    Thanks for your help.
    I just won't solve this problem right now because I am a little too busy lately (playing). ^^
    Share this post

  8. #8
    Hi. It’s me again.
    I just wanted to say I managed to install the “Tribes of the East” expansion. I just opened the CD files and then opened the “setup.exe” file. Don’t know how I didn’t thought on this before.
    Anyway, here is the solution, if hapens of anyone have the same problem.
    Share this post