1. #1
    ok I was really on the Right Track, here is my solution; if it does not work for you from my solution it's you don't wait long enought, but at least I got rid of the EKSHADERDATABASE ISSUE ( BLACK SCREEN OF DEATH ).
    first of all, Im able to run the game on my Vista x64 and x86 with the same solution and both of them were not working before. ( 2 different Hardware ( 1 as ATI and the other Nvidia )

    uninstall the GAME,
    Reinstall the Game
    Don't launch the Game from the DVD or the shortcut.
    Go where your game is installed EXEMPLE:
    ( c:\program files\shaun white snowboarding\ )

    Then look for the file named:
    ShaunWhiteSnowboardingGame.exe RUN THAT ONE not the other one.

    Then wait a bit and your game should start ( depending of your system it can take 5 seconds - 1 minute, so be patient.....! Also don't click on the blackScreen just let it do it's trick, if this fix your Issue please let me know.And Also Rate my Post, that way everyone can fixed it..!

    to Ubisoft now....
    Please Patch your Own Patch, it does not work on several systems. The Main problem of the database issue come from the patch it might fix some glitch but it might cause pain for a lots of peoples.

    Good Luck to everyones..! Smile

    PS: this is the fix until Ubisoft make another PATCH ( Version 1.01 is no GOOD )
    Share this post

  2. #2
    doesnt work
    Share this post

  3. #3
    Solution is here: Solution of the shader error
    User SGT.Heartless has solution, which is on 99% functional. More just settings in Windows XP by the ShaunWhiteSnowboardingGame.exe comptability example on "Windows 98". Check please file EKShadersPC.BIN in C:\Documents and Settings\All Users\Application Data\Ubisoft\SWSnow. This file has size roughtly 5811029 bytes. Without this file, game not run! Viz. next page on this URL.
    Share this post

  4. #4
    Perhaps is someone has no problems they can check the Ekshader file size against what was posted above. If your file size differs then perhaps thats the issue...

    Im peeved to hell that this issues is so old and still no fix..
    Share this post

  5. #5
    also, I have tried every forums, every solution offered, short of removing the game and reinstalling it because i got it from Steam and dont want another 8gb download.

    Nothing works. The fastest way to get this resolved it keep emailing the ubi suppoort team.

    Sooner or later they may pay attention.

    You would think one of them may even respond to the forums occasionally to keep their customers informed.........or is that asking to much
    Share this post

  6. #6
    As posted on other threads.

    I deleted my Steam Copy
    Purchased a new copy...same issues.

    However, I then reinstalled and then ran the patch without starting the game
    Restarted the PC and all is good.

    Side note - Nvidia users, I also added both EXE files into the 3D option in the Nvidia Control Panel, dont know if this helped
    Share this post

  7. #7
    I've just done what Lubos1987 said, and the file was only 225KB.... It's kinda gay, buying this game from Steam, 1 hour and some downloading, and the game doesn't work. THx Ubi. And i tried patching, Can't! I have version 1.000000 Instead of 1.0 !!! ...
    Share this post

  8. #8
    Hi guys! the solution for the problem is very simple!
    1. Disable Full screen Mode
    2. Set the maximum resolution you got (for me is 1680x1050)
    3. Than it's all about your computer set "Graphic settings preset" to
    Whatever you want!
    Hope it works for you cuz' it worked for mee
    If it doesn't work, please continue sending emails to Ubi
    Share this post