Thread: H6 release v : "system cannot find the specified path" | Forums

  1. #1
    Game won't start, "The system cannot find the specified path"

    Has anyone else seen this error? I have the Amazon version. When I tried to launch the game after first installing it, I downloaded the patch. At the end of the patch installation process, I got the error message in the title. Whenever I try to launch the game, via autorun, shortcut, or any of the .exe files in the game's directory, the Heroes splash screen appears and just sits there. The Ubisoft Game Launcher never shows up.

    I've tried reinstalling multiple times. I've installed the Ubisoft Game Launcher separately. I've deleted everything having to do with the beta and the demo, including leftover registry keys. I'm really stumped here. Anyone have any ideas?
    Share this post

  2. #2
    This is happening to me too.

    I did have the demo installed (not the Beta) and deleted it before installing.

    I've since tried uninstalling and reinstalling but keep getting the error "System cannot find the path specified" when trying to launch
    Share this post

  3. #3
    Anyone? I replaced the .exe with the new one that is meant to fix the startup black screen issue .. except now I keep getting "system cannot find the specified path" again ..

    I've totally uninstalled, reinstalled - removed the profiledata totally ...
    Share this post

  4. #4
    system specs:
    i2600K 3.4 ..
    240Gb SSD system drive
    Windows 7 64 Ultimate
    Nvidia 9800gx2 video card
    8gb RAM
    Share this post

  5. #5
    I've tried every posted fix I can find. Port forwarding, video card driver updating, the qt.conf fix floating around, the unofficial black screen .exe fix, reinstalling Ubisoft Game Launcher separately, closing my antivirus. None of it's working. I'm starting to think we'll have to wait for an official fix on this one.
    Share this post

  6. #6
    Exact same problem here, game is completely unplayable.

    Got "The system cannot find the specified path" then if I attempt to run the game direct from the executable, autorun etc the heroes splash screen pops up and sits there indefinitely.

    I've also tried reinstalling multiple times and have uninstalled and reinstalled the Ubisoft Game Launcher separately, I never had the demo or the beta installed at all. Have tried basically everything else people have suggested on the forums, nothing seems to help. Anyone have any ideas?

    System specs:
    Intel i7 2600k @4.7ghz
    8Gb DDR3
    120Gb SSD as system drive
    1TB SATA 7200RPM HDD (steam install on here)
    2x nvidia GTX560-Ti's in SLI
    Windows 7 Professional 64-bit
    Share this post

  7. #7
    Managed to fix this and get the game running.

    Required a full format of windows and my both other hard drives. An old install of Steam was conflicting with my new install of Steam that i'd created after getting my SSD. On a fresh windows install with a new steam install, game works fine now.

    Re-installing steam just by itself did NOT fix this, required fresh windows install then fresh steam install on top. Hope this helps anyone else with similar issues.

    Seems odd that this game was the only one affected by this, all my other steam games were unaffected. But at least it's running now..
    Share this post

  8. #8
    Found the problem. Went through my registry looking for any paths under the relevant Heroes version - there's one key which points the game to where profiles etc are kept - it uses a the system variable for "My Documents" - I don't have mine in the usual place and I don't have a My Documents directory set ... so go into the registry and change the path to an explicit one where you've made the directory already ... I did mine to "c:\homm6" .. then it started up no problem
    Share this post

  9. #9
    I tried to change the registry but I still Can't get it to work can someone help me out?
    Share this post

  10. #10
    I have the same problem, the thing is that I tried to start the game at office and the game works but home it just give me the same error.

    Do not know how to solve it...
    Share this post