1. #1
    pennyuk's Avatar Settlers Moderator
    Join Date
    Dec 2001
    So many people are asking the same questions when they come across an error message in game,there are so many posts with an answer given,yet they still post without searching the forum for an answer.The most common errors in S4 are
    Fatal Error: Exception 0x0000094
    Fatal Error - 0xc00000005 both are followed by another set of numbers,those numbers just tell you where abouts in your memory the error is occuring.

    Both these errors are compatibility errors.

    1.Make sure your game is patched to the latest version.
    2.Try changing the compatibility to 98/ME,to do this go to your S4 folder open it and find the s4.exe right click it,select "properties" here you will find the box to change to run in another mode.
    3.There was a new patch released not long ago,which helps solve this error,you can download it from :http://files.filefront.com/Settlers_.../fileinfo.html

    If after trying all these solutions and still the game doesnt work,then please post again.
    Share this post

  2. #2
    HI, after changing the compativility of my game set up from 95 to 98, i still founding tyhe same fatal error, then i change it to 2000 because is my windows version but still apearring the fatal error. then i download the patch and even with this patch my game is ruined with the fatal error. what can i do? thanks julian.
    Share this post

  3. #3
    double check that you are using the version
    not 1516
    don't forget about the little "a" at the end of the file version
    Share this post

  4. #4
    hi im playin the demo and ive tried to install the pathches some worked some didnt but it still doesnt work i got the ocx 001blah blah blah message so then i switched the compatability to win 98/ me and i got a whole different error mesage it says: software 3d error initionlizing graphic interface and below that it says: hardware 3d error initializing graphic interface. can anyone help me with this
    Share this post

  5. #5
    I very like Settlers 4 game.
    I can't play with Settlers 4, because I setuped the Windows Xp x64 OS and the Settlers 4 was posting a error message and the game not run.
    Please help me.
    Thank you.
    Share this post

  6. #6
    Sorry I forgot, my config: AMD Athlon 64 3500+, MSI K8N Neo4 Fi,Seagate 120 gb 7200 rpm, MSI X800XL 256 Mbyte PCI-E, 1 Gbyte HC Kingmax 500 MHZ RAM.
    Share this post

  7. #7
    Hewwo all! I hope i'm doing this right?
    For some unknown reason i couldn't load my saved games on S4 and then i was prompted to re-install it. But when i try to install it i get
    "Error when copying data:-106, Component:Game/GFXs, File group:GFXs, file:O.gfx. At about the 70% mark.

    Am i doing anything wrong?
    Share this post

  8. #8
    I get the memory error randomly (although more often whe playing a downloaded map). I've got the latest version, the 1516a patch, but still get the error. I tried putting it on windows 98/me compatability but that just makes the game minimize to the start bar after a couple of seconds. HELP please!
    Share this post

  9. #9
    Now then, this is my story battling with the 0xc0000005 exception, I hope someone finds a solution for their problems here.

    I'm running a P4 with Hyper Threading under Windows XP SP2. This is a doomed configuration with Settlers I think, since I've seen about half the world complain... Also, I only have the basic version of the game, no add-ons. (hear the funeral bells ringing)

    I tried each and every solution I found in the net, be it on these forums or elsewhere. The results were not too great. But then I found a new solution, which fixed everything.

    At first my game didn't start up at all, I got the 0xc0000005 error after a bit of loading, before seeing anything of the game. So I thought updating the game might help. I got the 1516 patch off the website and... the same result. Then I searched for the 1516a patch as suggested in this post, found it, installed, and the game was still not starting up.

    Next step: Compatibility modes and the Application Compatibility Toolkit. Okays, with the option "Emulate slow CPU" checked from within app. comp. toolkit, or with 98/me or 95 compatibility modes, I got the game to run. Problem solved? NO! After a while of gameplay, the thing still crashes.

    Back to searching the internet for answers. Some people had noticed it tends to start crashing when the total settler count of all players reaches a high number, which did indeed seem true. The game started to crash only when it had been played for quite a long time. But then again it's impossible to play like this, since in already the very first of maps in the single player campaigns the population count got far too high to ever finish them without crashing.

    Okays, some people had noticed it's the population count that triggers the crashes, but they had found no remedy for the crashes. So, I was back in square one, searching the internet.

    I thought of checking out what a fatal error 0xc0000005 might be, in hopes of finding a cure.

    It turns out 0xc0000005 is an access violation, meaning the OS has locked the part of memory off that Settlers 4 is trying to use at the moment of crashing. Bad (and ancient) memory management might be a cause of this, when the programmer tries to use memory used by another program. But in this case it's not the programmer's fault, Settlers 4 does work in other configurations, so the problem has nothing to do with memory management.

    And behold. There IS an answer (even after all these millions of lines of text, YES THERE IS AN ANSWER).

    The thing that closes off the memory areas used by Settlers is a thingy called Data Execution Prevention, built in Windows XP SP2 at least. It blocks off the execution of some memory to prevent virus damage, and apparently to prevent Settlers 4 from working. :E

    Hopefully, you can configure it to ignore the Settlers 4 executables, and, woohoo, everything works. Without compatibility modes, without anything. Just plain works. :O

    Now here's what you do:

    1) Right-click on My Computer (on your desktop or in the start menu usually), and select Properties.

    2) Select the "Advanced" tab, and therein choose the performance settings.

    3) In performance settings, you have the "Data Execution Prevention" tab. Choose that.

    4) Choose the "Turn on DEP for all programs and services except those I select:" option, and add the Settlers 4 executables into the list. Those being:

    \Your Settlers IV Folder\S4.exe
    \Your Settlers IV Folder\Exe\S4_Main.exe

    Might actually work if you only add the \Exe\S4_Main.exe one. Anyhows, I hope it helps someone.
    Share this post

  10. #10
    Just like Ilnore I tried every solution I could find on the net for the 0xc0000005 exception.
    Nothing worked, I just tried the solution from Ilnore, but that didn't work for me either :-(

    The game still crashes with the exception, only change is that now it explorer craches with it, it didn't do that before.
    Share this post

Page 1 of 5 123 ... Last ►►