1. #11
    I tried submitting a ticket for this issue. Holy crap, remind me to never buy another Ubisoft game. Their support personnel aren't even moderately intelligent. They actually messaged me back telling me to go hang because my computer "doesn't meet the minimum system requirements". Which is odd, because it actually far exceeds the Recommended requirements. I asked for clarification, they said it was my processor. Apparently a Core i5 750 doesn't meet the requirements for a game that will run on a Pentium D. Not to mention, the game itself runs fine. What an utterly unhelpful waste of time, I'd really rather they just ignored my ticket if they're going to be that stupid about it.
    Share this post

  2. #12

    Hello! I have the same problem.
    When I bought the game in September, 2012, I could play multiplayer normally about 1 year. Then the game bothered me and I forgot it. In May, 2014 my friend bought this game to play together, then he faced to this issue. I did not anything with my copy of the game: it kept on HDD. I ran it then I got this is issue too.
    Two weeks ago I installed Driver:SF on my new PC (i5 750, GTX970, 8GB RAM), and today I CAN'T PLAY MULTIPLAYER TOO!!!
    It was a last Ubisoft's game in my basket. Only torrents, only hardcore!
    Share this post

  3. #13
    Me and my friend too , global
    Share this post