1. #1
    When I click install, it won't do anything.Plus even when I click on setup.exe file it doesn't do anything.Help!
    Share this post

  2. #2
    steve_v's Avatar Senior Member
    Join Date
    Apr 2002
    Posts
    7,895
    When released almost 10 years ago, the supported OS were Windows 98 / Me / 95. IIRC, it also would later work with 2k and XP. It doesn't with Win 7.
    Times change.
    Share this post

  3. #3
    I have vista though.
    Share this post

  4. #4
    steve_v's Avatar Senior Member
    Join Date
    Apr 2002
    Posts
    7,895
    Originally posted by corleonejp:
    I have vista though.
    You have three options to fly the original IL-2 Sturmovik. They are listed from difficult to simple.

    1. Using your own computer acumen and self-reliance, you discover a way to install and run the original on an unsupported OS. (Vista in your case.) Every now and then someone asks, so there is still a small interest.

    2. Install a supported OS on a separate drive or dual boot.

    3. Acquire 1946, which was released in December 2006, which contains the entire IL-2 series, including all of the material from the original. This should cost somewhere between US $5.00-10.00 and can be downloaded rather than Amazon, UbiStore, ect. It will install and run on Vista.

    With the release of 46, there hasn't been much interest in the individual sims that make up the series.
    Share this post

  5. #5
    My original IL-2 worked on Win7 32 bit before I got 1946 as a Christmas present.

    1946 is cheap as bread these days, go and get it. It has like 10 times the content of original IL-2.
    Share this post

  6. #6
    M2morris's Avatar Senior Member
    Join Date
    Feb 2006
    Posts
    1,856
    You can probably get it to run on Vista with alot of right-clicking and 'run as administrator'
    hassling.
    Go to the DVD and click 'Open'
    and then find the setup file and run as administrator. That might work.


    Edit:
    It worked. I got the old IL 2 Sturmovik to install on Vista, although I aborted it as it was installing, it was installing.
    I went to the dvd and right clicked, then clicked 'open' and right clicked the 'UBI/32 set-up icon, and then 'run as administrator', and then 'allow'.
    Share this post

  7. #7
    So, 1946 does install on vista? I've heard that it doesn't work either.Even on steam it says only for xp/2000.
    Share this post

  8. #8
    Originally posted by corleonejp:
    So, 1946 does install on vista? I've heard that it doesn't work either.Even on steam it says only for xp/2000.
    Don't get the steam version of 1946 (some odd issues), but 1946 does work even though it's not documented as supported. 1946 and the latest patches (4.08, 4.09, 4.10, and 4.10.1) are needed for online play, as far as I know there is almost no one playing the original online whereas 1946 can have several hundred online at any time.
    Share this post

  9. #9
    Cool, thanks a lot guys.Looking to getting 1946!
    Share this post

  10. #10
    By the way is this game joystick compatible?
    Share this post