1. #1

    Settlers - Rise of Empire

    I've been catching up with Settlers after many years' absence. I recently installed Settlers V and the Expansion Disc and played them without any techinical problems. I today tried installing Settlers VI Rise of Empire, and it appeared to load correctly, though when I started to play it then tried to install a patch which came on the same disc. This ended up with a message to say that the full game was later in date than the patch, so it was not loaded. Since then I've tried a few times to get started. Some times I get as far as choosing the knight to go out on the first mission, and sometimes I only get as far as the first video, ending up in the market place, before identifying the knight. It then crashes without any indication of why (I get the usual microsoft message saying its trying to find a solution, but it can't).

    So if anyone can advise me how to get over this problem I'd be grateful.

    I'm running this on an Acer Aspire laptop 5613ZWLMi, with Intel Pentium dual-core processor T2080, 2GB DDR2, and Intel Graphics Media Accelerator 950, under Vista Home Premium.

    I've tried running with, and without, Games Booster from Iobit.

    Share this post

  2. #2
    BTOG46's Avatar Global Moderator
    Join Date
    Mar 2006
    If you have the Gold edition, you may get a message that the version you have is newer than the patch, for some reason, some of the Gold editions don't recognise that the patch is indeed newer than the existing game version, but that's fixed easily.

    Go into the folder the game is installed to, look in both Program Files/Ubisoft/THE SETTLERS-Rise of an Empire/base/bin and Program Files/Ubisoft/THE SETTLERS-Rise of an Empire/extra/bin and if you see a config file called "s6patch or s6patch.ini" delete it, then manually download and install Patch 1.71 which will remove the copy protection and allow playing without the disc.

    Your video chip is a bit low performance for the game, you need to go to the game graphics options and set it to the lowest settings and resolution, if it works ok, you could then try raising settings one at a time till it crashes again, then go back to the previous setting
    Share this post

  3. #3
    Many thanks - I realise the problem now.

    I've also begun this game on my new computer, much more powerful! I have some games issues though:

    I can't find out how to purchase goods from a cloister - they don't have a storehouse to which I can send my knight.
    In 'Last Resort' I can't find out how to get more iron, so that I can make more weapons to defeat the bandits. If I use the knight to do so, it will take for ages, and I suspect the bandits will regenerate before I can get rid of them all (since the knight has to retreat after each 'kill' to regenerate, and I can't get him near any of the tents to destroy them - if indeed he is able?).
    I don't know how to get hold of that cart which I have to prevent arriving at its destination. My knight doesn't seem to have the power to stop it!

    Any ideas, or hints, please?

    Many thanks
    Share this post

  4. #4
    sings_in_tune's Avatar Moderator
    Join Date
    Mar 2011
    Southern Ontario, ...................... Canada
    In the territory behind your cathedral - Rena Mines, there are two iron mines.

    The icon for trading appears over the cloister later in the game. Maybe after they receive the animal carcass.
    Share this post