1. #1

    I've been playing Riven on iPhone, and the Fire Marble Puzzle does not seem to work. I've triple-checked my solution, and yes, I did make sure to not only pull the lever, but also to push the button that that lever reveals.

    However, it never powers up. I checked the linking books inside the spinning domes, and they are still not powered up. I think this is a bug. When playing Riven on the PC, I've never had a problem with this puzzle.

    I thought maybe the solution was changed up a bit on the iPhone version, just to be sneaky, but I get the same information on symbols and colors, and I tried swapping the blue marble out with the yellow one, but that doesn't work either.

    Up until this point, I hadn't experienced a single bug, and it has been an excellent port, but this bug is game-breaking. Maybe I'm wrong, and it's not a bug, but I can't seem to pinpoint any other explanation.

    I have an iPhone 4S, fully updated.
    Share this post

  2. #2

    Have a look at this thread on the MystCommunity forums and with the possibility to also ask for help over there(after registering)... click here

    I suspect it has to do with color's recognition on a screen as small as you have on a Iphone.
    re: the red & the orange or... possibly between pink and red... and why not >>> between orange and yellow.

    See spoiler image for the solution...click here
    Share this post

  3. #3
    Ah, screw me.

    No, the color wasn't the problem, but I found out that it wasn't a bug. The marbles show up bigger on the iPhone version, and block about 9 of the pegs, so it's hard to see the exact placement of each marble. I had one marble one notch off.

    No bug. It works. Oops.
    Share this post