1. #1
    Hiya all,

    I seem to be having trouble these days with vertical refresh synching.. I have tried forcing it on using "ATI Tray tools" and in the video driver.. all to no effect. I always use vsynch and it seems to work fine in other games, just IL2/PF that has recently had the problem.

    I think.... and I am really not sure here, but I think it stopped working after I went to 4.05

    I have tried the game in OpenGL and DirectX with similar effect.. although in OpenGL the frame rate seems capped at 50fps (monitor is refreshing at 60) and tearing is still a problem.

    Anyone else have this trouble or have a suggestion?

    For reference I am running catalyst 06.3 with a radeon 9700 on win XP (SP2??)

    Fifth_Columnist<div class="ev_tpc_signature">

    "One of God's own prototypes. Some kind of high powered mutant never even considered for mass production. Too weird to live, and too rare to die." - Hunter S. Thompson
    Share this post

  2. #2
    Hi
    Leave v sync disabled and use say 2x anti aliasing,then go to advanced or whatever its called(second tab on ATT ogl settings board )and select temperal anti aliasing,set the multipler at 2x and in the bit to the right select manual and type 60.
    I have a ati1900xt now but i used to have a 9700pro and temp aa used to work on that.
    I also set my monitor refresh rate at 85hz on the windows display advanced option(in control panel),which is the max my monitor can do at the res i use,then set the ATT refresh rate setting to "same as desktop" , i find this method ,stops tearing when using trackir and also gives good fps as temporal aa uses less resources. Good luck!
    Ps after reading your post a bit more im not sure if you have the catalyst control panel aswell as ATT.Id recomend removing your present driver and control panel and just downloading the 6.10 drivers only(Below the others in the low speed seperate section NO ccc) and just using Ati tray tools(ATT) to do your settings.
    Share this post

  3. #3
    Hi Fifth
    Can't help a lot but just thought I'd say that I have a similar setup - a 9800XT in WinXP with a TFT monitor. Drivers are 6.9 with CCC. Vsync is on as I use a TrackIr 2. Game version is 4.05m running in OpenGL and I have no problems such as you describe.
    Hopefully someone else can offer advice, good luck to you.<div class="ev_tpc_signature">

    Share this post

  4. #4
    WWSensei's Avatar Senior Member
    Join Date
    Dec 2001
    Posts
    1,324
    Vsync in DirectX isn't supported in IL2. Been an issue since the original version.<div class="ev_tpc_signature">

    --------------------------------------
    "A lady came up to me on the street, pointed to my leather flight jacket and said, "Don't you know a cow was murdered for that jacket?" I replied menacingly, "I didn't know I left witnesses. Now, I'll have to kill you too."
    Share this post

  5. #5
    Thanks for all your help all, I have tried fiddling arround with the settings with minimal success, still got some tearing but its not as bad as it was. I will try rolling back to 6.10 drivers at some point and see if that cures it.

    Fifth_Columnist<div class="ev_tpc_signature">

    "One of God's own prototypes. Some kind of high powered mutant never even considered for mass production. Too weird to live, and too rare to die." - Hunter S. Thompson
    Share this post

  6. #6
    With Vsync on enable Triple Buffering. And in IL-2 setup enable S3TC Texture Compression and you will see better frames and better quality without tearing with the card you have.

    Let me know how it works for ya.

    BTW Triple Buffering is easily enabled using ATI tray tools.<div class="ev_tpc_signature">



    VMF-214 The Original Black Sheep Squadron of the IL-2 series are currently recruiting dedicated and mature pilots. Visit us at http://vmf214blacksheep.com/
    Share this post

  7. #7
    S3TC + vsynch although it seems a little more fluid the tearing is still occuring..

    One interesting thing... I have the on-screen FPS meter running from ATT and notice that the frame rate seems to be capping at 50 (in the menus and while the 3d engine is running), my display is running at 60hz and before I had this tearing thing it always used to cap at 60 fps.. strange.

    Fifth_Columnist<div class="ev_tpc_signature">

    "One of God's own prototypes. Some kind of high powered mutant never even considered for mass production. Too weird to live, and too rare to die." - Hunter S. Thompson
    Share this post

  8. #8
    Hurragh, problem solved.

    I uninstalled display drivers + 2 versions of the ati control panel + att and replaced with catalyst 6.10?? (no control centre thing) and latest version of ATT, with a bit of fiddleing around it seems to have solved the vsynch problem and I seem to be getting a slightly better frame rate.. not benchmarked so couldn't be completely sure.

    Thanks for all your help

    Fifth_Columnist<div class="ev_tpc_signature">

    "One of God's own prototypes. Some kind of high powered mutant never even considered for mass production. Too weird to live, and too rare to die." - Hunter S. Thompson
    Share this post