I purchased this game and could not play it for a few days, always same error: "Failed to set display mode."

My system:

System Information
Time of this report: 06/3/2006, 15:40:03
Machine name: ARES
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
Language: English (Regional Setting: English)
System Model: MS-7100
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: AMD Athlon(tm) 64 Processor 3800+, MMX, 3DNow, ~2.4GHz
Memory: 1024MB RAM
Page File: 286MB used, 1020MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.2180 32bit Unicode

Display Devices
Card name: NVIDIA GeForce 6600 GT
Manufacturer: NVIDIA
Chip type: GeForce 6600 GT
DAC type: Integrated RAMDAC
Device Key: Enum\PCI\VEN_10DE&DEV_0140&SUBSYS_00000000&REV_A2
Display Memory: 256.0 MB
Current Mode: 1280 x 1024 (32 bit) (85Hz)
Monitor: Default Monitor
Monitor Max Res:
Driver Name: nv4_disp.dll
Driver Version: 6.14.0010.8195 (English)
DDI Version: 9 (or higher)
Driver Attributes: Final Retail

Tonight, I finally found the fix!

Changing memory options from 'System cache' to 'Programs' fixed it!

This was 100% positively my problem. In fact, I can toggle it back to 'System cache' and the game no longer works. The same error: 'Failed to set display mode' will appear.

I have tested this 10+ times to make sure it was my problem. I can easily duplicate the error by simply changing this setting.

If anyone else wants to test this:

1.) Right click 'My Computer'
2.) Click Properties
3.) Click on the 'Advanced' tab
4.) Click Settings button in the 'Performance' group.
5.) Click the 'Advanced' tab
6.) Look to the 'Memory usage' group, and toggle it from System to Programs.

I am curious if there are other people with a similar system setup as mine with the same problem. If you test this method and it works for you, please post a report back in this thread.