1. #81

    Probable solution for the non-occuring landbringe

    Okay, first off, I have the PC version and had the exact same problem. The landbridge to the jellify water village didn't surface.
    Here's what you do (at least what helped me) Turn your resolution down to 600x800 and for some reason it works then. Add a little dirt and once you have the jellifying and amplyfying this entire stage is a cakewalk.
    So yeah.. maybe thatswhy no errors occur on the 360, lower graphics by deafult... hope this helps!
    Share this post

  2. #82
    NTTD's Avatar Junior Member
    Join Date
    Jun 2012
    Had the same issue here, Tide was rushing in while the basin was still full.
    Funny thing though, when I started the game after reading this thread the level was functioning normally. There was actually time for the tribe people to get across.
    It still took a few cycles because they would often try to cross too early and be swept away, or be queued in the wrong location and take too long to get to the correct one.

    For those having this issue just keep restarting the level (as mentioned before) until it works right. you'll notice the difference at the first tide cycle. It was night and day, I saw parts of the island when the tide receded that in previous plays were always submerged. The central basin drains about 99% before the next tide cycle comes in.
    I found that moving the jellify water village close to the the infinite earth one, gave them just enough time (when using jellify water) to build that village and get the repel water knowledge kite there. It took a few times for the timing to work out, but it did in the end.

    Originally Posted by minusthedrifter Go to original post
    If this video is similar to what other people are experiencing than the problem isn't a bug it's your PC.

    Does the water in previous levels also act like that? It's way to jellified, it should be a lot more fluid, like real water. When you drop a handful of water it should not build up like it does at 3:50, or at any other point in the video.

    The problem appear to be that your PC isn't able to handle the water physics in that level. Or perhaps all levels if water always acts like that. It could be that since that level is almost entirely water, and moving water at that, your PC doesn't have the processing power it requires to render and move all of the water physics.

    So, does water always act like that? Further what are your system specs?
    Originally Posted by minusthedrifter Go to original post
    What kind of graphics card do you have then? Though other than the water your game appears to run smooth enough... Has water always acted like that? It might just be the mass amounts off moving water that's bogging your PC down.

    Double check as well that all your card drivers are up to date and see if closing some background tasks help at all.

    It really does look like a PC problem over an actual bug. Take a look real quick at this video, notice how much more fluid the water is and how much more quickly it flows out.


    Since your water is moving so much slower it is unable to drain before the timer hits. If it were flowing how it is suppose to flow you'd be money.

    If all else fails you could always just try a reinstall to see if perhaps your water physic files were bugged or something.
    I don't thing processing power is the issue, at least no in my case. I'm running two 9800GT cards in SLI and yet still experienced this (can run Arkham City on fairly high settings).
    The issue , as I see it, is that the tide timing cycle was increased, I did not notice a difference in the flow of the water. In the "bugged" version the tide timer would restart again after a short time (under a minute). Finally after several restarts, the time between tide cycles was much longer (well over a minute, maybe 2+) giving enough time for the water to drain.
    Also the fact that it can behave differently on a restart of the level tends to point to a bug, and not a PC issue.
    Share this post

  3. #83


    Originally Posted by Kaupo2008 Go to original post
    Okay, first off, I have the PC version and had the exact same problem. The landbridge to the jellify water village didn't surface.
    Here's what you do (at least what helped me) Turn your resolution down to 600x800 and for some reason it works then. Add a little dirt and once you have the jellifying and amplyfying this entire stage is a cakewalk.
    So yeah.. maybe thatswhy no errors occur on the 360, lower graphics by deafult... hope this helps!
    That worked for me! Was running at 1920 x 1080. Adjusted to 800x600 and wow, that looked bad on my 25" screen. But the water worked perfectly and I was able to easily beat that level after spending hours on it prior to finding this thread. Had not been that frustrated with a game in a long time.
    Share this post

  4. #84
    My Media Center PC has this issue and I'm willing to bet it's the frame-rate causing the issue. My gaming rig had no problem with the level and the water levels receded appropriately.

    If the level starts at a high tide and your frame rate is low, then the water will take longer to leave. The timer, however, works on real time and not frame-rate. So if the tide only has 10 seconds of in-game time to recede than the 30 seconds the games THINKS it's giving you, the tide will just stay really high. If your frame-rate is fast enough, the water will have plenty of time to lower enough for the land bridge to be revealed.

    Unfortunately, I don't know of any tweaks to making the game run any smoother beyond lowering your resolution. The game offers no real performance options. Your best bets would be to transfer the game saves to a PC that can run it and continue from there, or use a cheat. I don't know the rules of the forums so I won't mention anything else about them.

    And it wouldn't have any errors on consoles because I'm sure they optimized it on those machines. They don't have to guess what hardware is being used unlike PC games. So find ways to increase your frame-rate, or bum someone else's computer. I doubt it will be fixed by the developer.
    Share this post

  5. #85
    Lol i cant believe people are still having trouble with this level. Its not impossible. I have finished it without get any of the other totums. It is not a frame rate problem. Used my brothers PC (just meets minimum requrements) to play the level and there is no difference to the game (except graphics and the occasional crash) to my 16b ram power PC.

    I posted a screen on this thread a while back on how i do it. Only takes 35-45 min to complete. (bottom of page 5)
    Share this post

  6. #86
    For what it's worth, I can confirm without question that the problems people experience with the water not receeding far enough is most certainly a issue with PC performance. I recently upgraded from a computer that barely met the minimum specs for the the game to a i7-2600 w/ 16GB but kept the same video card until I could afford a new one. The level was equally unbeatable with both configurations and the old video card (Radeon HD 3650). I recently purchased a new video card (GT640) and the first time I loaded this level it was immediately different. The water is completely different.

    The same goes for the challenge level "Atlantis"... previously the islands didn't come up far enough and I couldn't get my villages bult in time. With the new graphics card all of the problems have disappeared.
    Share this post

  7. #87

    A bit tricky, but quite do-able

    Old thread, but FWIW I beat the level on a bog standard PC (Athlon twin core, 4GB memory, Win XP) with the short tide interval. On the most direct crossing, I used a combination of sand bridge (for the side nearest the village only, water grab using the enhanced level (3 key) and then dropping the water to wash the followers to the island. It's the last trick which makes the differenece. Get 5 warriors to the jellify water totem, then it's easy to get the infinite earth totem (in the middle of the big lake). Get the repel water totem first, then apply jelly on the lake totem at lowest tide (so that there is less water to scoop) and the jelly holds back the incoming tide. It takes two cycles to do; the first to get your followers to worship the totem then, when they've been washed away, they get there quicker the 2nd time and there's time for the repel water spell to be propagated. Once you have infinite earth, you can raise the 3rd totem high enough that it doesn't get flooded. After that, you can play around making lots of new land and taming those tides. Just be careful where you place the fire tree! I was just about to finish, having turned the entire map to land, when I got burnt out lol.
    Share this post

  8. #88
    sings_in_tune's Avatar Moderator
    Join Date
    Mar 2011
    Southern Ontario, ...................... Canada
    I just got a new video card because my old one melted. And when I went to play the high tides level (my favorite) it was just different. I never had a problem with the first village being washed away with the old card, now I see what people are talking about, the water washes right over it where before the water just caused minimal damage. And the tides are just different, they are slower or something, I can't really say how, but just different. I can still do the level but who would think that a different video card would change the game like that.

    So you really don't know what other people are seeing.

    PS: my old card was an Nvidia Geforce 9500 GT
    Share this post

  9. #89

    Same prob but found a way!!!!!

    I just got the pc game and high tides was making me so angry...I got so angry that I flooded my guys while they were trying to cross. By throwing water on your guys you can push them to the other side. After they are in the water you just keep pouring water the way you want them to go. Once you have jelly you can go back and rebuild your other totem.
    Share this post

Page 9 of 9 ◄◄  First ... 789