1. #21
    Hi Guys,

    Strange as it may seem, up until today I have never had the black box and didn't know what any of you were talking about.

    I have had a Samsung netbook for xmas (lucky me) and have installed the gold edition, but after realising how much of a pain it would be to have to carry around the external drive, I searched for a no cd crack. Well it worked, but as a bonus I now have this famous black box.

    Question is, I really don't want to go back to using the cd, as the netbook doesn't have an internal device. what are my options, as it looks like the Virtual software requires a cd player?

    FYI - all the games I have on the machine are direct downloads, and I haven't yet found a site that deals with any direct downloads for settlers 4, this and Total Annihilation are my most played games whilst working abroad, and yes, I have multiple sets of originals.

    Share this post

  2. #22
    Yes a virtual cd-rom drive program such as Daemon Tools, Alchol 120% or BlindWrite is what you're after.

    Though the fact that the patch gave you the blackbox bug would certainly make me advise you to get rid of it pretty sharpish as it's obviously causing some form of corruption to the graphics cards display.
    Share this post

  3. #23
    Any clue on why the save function is not working?
    Share this post

  4. #24
    pennyuk's Avatar Settlers Moderator
    Join Date
    Dec 2001
    Chief come back!!

    Is there a way to create a shortcut of the .exe from the VirtualBox,I sort of erm told it not to create a shortcut.My idea being WHEN I get the BBGC problem sorted,I want to be able to play via the server,but having not played for 5 years,I feel I will need a ton of practise games on SP,would just be good to not have the boxes,when in SP,I know until I swap this graphics card I cant have that in MP.
    Share this post

  5. #25
    Save Function:

    Try opening a terminal, and change directory to the s4.exe

    Then type:

    sudo s4.exe

    it'll ask for the password, then launch s4 - see if the saves then work.

    Shortcuts I think you can right click and choose make link in the exe folder, then drag n drop to desktop.

    If that fails see if there's a Desktop folder in /home/s4 and if there is put the link there.
    Share this post

  6. #26
    Hey Chief! Thanks a lot, I always loved this game when I was younger, and I really looked forward to playing it again, and now it finally seems to work =) Still there were 3 problems I ran into;
    - I can't get the graphics right, shadows seem to be made out of dots and all that, it just doesn't look all that pretty (that's alright though, if you don't know how to fix it just nevermind =) )
    - The keyboard doesn't seem to work in the game
    - I can't find the directory of the map editor; is there a way to use the map editor on the Virtual Box? Or a way to use map editor on my own computer and then import the map files onto the Virtual Box?

    Anyway, thanks a lot!

    Share this post

  7. #27
    - Graphics are never going to look very good as you cant turn on all the hardware rendering options using virtual box.

    - Try leaving fullscreen virtualbox and re-entering it and see if that cures it.

    - Isnt the map editor a seperate install? My mission cd corrupted yonks ago so havn't used the map editor or installed it in ages, isnt it just a folder called "Editor" in the s4 folder with the exe in that folder?
    Share this post

  8. #28
    The keyboard still isn't working, but thanks for your suggestion anyway =). I guess the game can be played using only the mouse, when necessary.

    The map editor is installed automatically when you install the mission cd, but I've got the Gold Edition cd, which installs the game together with the mission upgrade and the editor at once, so it's not a seperate install. The editor is however started with a seperate .exe file, which can indeed be found in the S4 installation folder (on my computer in program files, blue byte, etc). the problem is that I can't find the installation folder on the Virtual Box, I can only find the cd when it comes to Settlers IV files (and the shotcut on the deskop). If you do know where I can find the folder where S4 is installed on the Virtual Box it would be helpful, but if you don't then I'll just live it it, I'm very glad it's working to begin with and these are just minor things.

    Share this post

  9. #29
    Use the file manager (see faq) and type this in the address bar (followed by enter/return):


    Then just double click on C (or c_drive its called something) and then bluebyte>s4>editor> or if you changed the default install path, find whereever the folder is.
    Share this post

  10. #30
    I'm having trouble with downloading it from
    it just download about 13 mb or so then it say download complete I'm using Firefox 3.5 didn't try normal internet explore yet tho but I doubt that that is the problem... Don't you know about any other way of fixing the prob maybe because its maybe like driver kinda problem, cause I know populous the beginning... I had smiler problem with it it was just a small hardware setting but I'm not sure its the same problem really tho but please reply as soon as possible
    Share this post