1. #1

    Cable not Working - Win10

    Seen many threads about this and been trying everything I can to get this working with no luck.

    I was given Rocksmith for PS3, but I'm more a PC guy so sold the PS3 shortly after buying it. Played the games maybe 3x so the cable is essentially new.

    Got Rocksmith for the PC (Steam) and trying to play but getting absolutely nowhere.

    I have tried USB2.0 and USB3.0, front and back ports, unplugging other devices, setting USB root hub to not allow computer to turn off device under properties, went into the BIOS and played around with XHCI, etc... constantly getting "This device cannot start. (Code 10) The I/O request was cancelled." in the device manager.

    Never came up with the correct name though, which I read may be a power issue to the port.... so grabbed a powered USB hub that I had for a RaspberryPi project luckily, and plugged that in. Same issue as before, except now it shows as "Rocksmith USBGuitar Adapter" so I guess progress?

    Uninstalled, reinstalled, made sure microphone was set to sharing 'on'... and still when I start the game and go through setup it says it sounds like your cable is unplugged.

    I don't have a 2nd cable to test with, nor do I or anyone I know, have a PS3 to test on.

    Cable did work fine on PS3 when I used it, been in the box neatly put away for quite a while. Could possibly be defective but, leaning towards another issue given that it did work and hasn't been touched since.

    Was excited to play, now just getting frustrated. The Ubisoft troubleshooter wasn't helpful at all.

    What else can be tried on this? I think I've tried it all...except the USB-A to USB-C adapter, saw a few posts about that but no USB-C on my PC.
    Share this post

  2. #2
    Finally figured it out...

    1 - Unplug cable
    2 - Device Manager. Go to View-Show Hidden Devices
    3 - Expand 'Universal Serial Bus Controllers' and 'Sound, Video and Game Controllers'
    4 - Delete/Uninstall everything greyed out. Takes a long time because have to go one-by-one
    5 - Reboot system
    6 - Plug in cable (not plugged into guitar... not sure if makes a difference but it's what I did)

    I am using a small powered USB hub plugged into a USB2.0 port on the rear of the PC.

    BIOS wise, the XHCI I reset back to what it was before, smart detect or something like that. Disabling didn't make any difference for me except the boot time was longer for some reason.

    Spent hours on this and now after midnight, so bed. Tomorrow I'll maybe see if can work without the hub since not sure if was just a driver conflict? or a few things like drivers and powered hub, etc...
     1 people found this helpful
    Share this post

  3. #3
    So today, unplugged, plugged into the PC directly and Code 10 error again.

    No problem, just plug it back where it was, right?

    Nope... that was 30min ago. Right where I was before, deleting stuff and rebooting. Sometimes shows as usb audio device, hock smit, or the actual Rocksmith USB Guitar Adapter... depending which port I use... but always that Code 10 error.

    Using this hub in a USB2.0 port.

    This is some truly flaky $@#% they made for this game to work with. Never had something so finicky about which port it's plugged into and seems somewhat random when it decides to load with the correct name.

    Given the number of threads on this, I'm very surprised they hadn't made some sorta fix or exe installer for it.

    EDIT - 7-hub USB, 2A power supply... I had my keyboard plugged into it to recharge the batteries and the draw of power was enough to keep the cable from working. 1 device....how much power does this thing need?

    Seriously... anyone know?
    Share this post

  4. #4
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,683
    A hub that plugs into wall power will do better than a USB powered hub.


    Looks like the cable maybe uses 100 mA. From this thread:

    https://forums.ubi.com/showthread.ph...ration-and-FAQ

    Share this post

  5. #5
    Mine is plugged into the wall... as mentioned it's a 2A power supply, which is the same as 2000mA. Which is why surprised that I had to unplug everything else from the hub to make it work.

    Mine shows as having 500mA available max per port, so, if I was charging a keyboard, it would only charge at a max of 500mA, leaving 1500mA left for the remaining ports. The Guitar cable would have had a full 500mA available to it.

    Numbers don't seem to add up. :S
    Share this post

  6. #6
    rcole_sooner's Avatar Moderator
    Join Date
    Mar 2009
    Location
    Norman, OK
    Posts
    13,683
    The power supply being 2A, does not mean the hub will provide that much power.

    The hub probably supplies 500mA per root hub.

    If the keyboard and cable were plugged into the same root hub, then there would not be enough power for the cable.
    Share this post

  7. #7
    Swear this thing is about to go to the trash... every other day, I have to do the same thing... show hidden, uninstall, reboot, plug in, and if lucky I don't repeat it 2-3x to get the cable working.

    Powered USB hub, USB2.0 port, nothing else plugged in.

    Anyone else find it to be way too finicky?
    Share this post

  8. #8
    Once you get the cable working, how long does it last?

    If you want to check the cable you could use a linux live disc, no install needed.
    Checked mine that way and it shows up as: Microphone Rocksmith Guitar Adapter.

    If it shows up solid in linux through several plug/unplugs then its probably a bad Win10 driver.
    You will need updated drivers for USB root hub and possibly Sound as well from your computer or motherboard manufacturer.
    Share this post