Thread: & the game getting fps drops once again !!! | Forums

  1. #1

    & the game getting fps drops once again !!!

    It was running better with 1.0.7 update patch but after getting 1.1.1 update it started to get fps drops in some area , playing 229 hours . I'm very very happy with my Odyssey but fps drops are killing my patience
    Share this post

  2. #2
    One does wonder. My rig was running worse after 1.0.7 update then now with 1.1.1 update.
    Almost no frame dips. At least it is "exiting" updating and what comes next....
    Share this post

  3. #3
    I'm playing on PC as well .
    Share this post

  4. #4
    And here I thought it was because I save my game on an external drive. Nice to know it isn't just me. It gets really bad some times. There are occasions when I am in a fort or a cave and I am hiding and I turn to quickly and the frame rate starts jerking through. If I can turn around and get out of the area it usually lets up but some times the game just freezes up and I have to restart the game.
     1 people found this helpful
    Share this post

  5. #5
    Ubi-Zubi's Avatar Community Representative
    Join Date
    Sep 2018
    Posts
    1,150
    Hey everyone! Moving this over to the community support forums for visibility.
     1 people found this helpful
    Share this post

  6. #6
    I have 1080Ti. After the update, the FPS dropped dramatically. The graphics settings did not change.

    For some reason, the game is no longer loading the cpu / graphics card? I see it in fan speed and temperature.
     1 people found this helpful
    Share this post

  7. #7
    UbiSailorScout's Avatar Ubisoft Support Staff
    Join Date
    Sep 2017
    Posts
    5,058
    Hi guys! Sorry to hear about your performance issues with ACOD after the latest update. Since most of you are on PC, I'd recommend doing a clean install of your GPU drivers (AMD/NVIDIA). I'd also recommend running the game with background applications disabled. Some players have noticed increased performance after switching to Borderless Window mode. Let me know if any of these steps helped!
     1 people found this helpful
    Share this post