Thread: FPS Drops after Wind Bastion Uğdate | Forums

  1. #1

    FPS Drops after Wind Bastion Uğdate

    Hello guys,

    Simply I am experiencing new constant FPS'drops after the update. Before the update I was going on an average of 90 -100 FPS but now it is worse like 60 - 70 which is annoying. It also gives me huge fps drops back down to 30 - 40 when I get Echo droned or if the scene gets too complex with smokes and such.

    Specs are:

    i5 HQ7300
    GTX 1050
    16 GB

    Remember, before the update I had no problems so I am pretty sure this is a problem with the update. Now even in the main animation menu where Nomad is reading something, the FPS is constant 40 which is super low when it was locked to 60 during Grim Sky. Anybody has any idea? Or will Ubi fix someting like this?

    Thanks in advance
     2 people found this helpful
    Share this post

  2. #2

    Same

    I also have been getting the same issue, before the update i ran it on medium at 130-170 fps on medium setting i have a rx570, intel core i3 8th gen chip and 8 gb ddr4 ram now i am getting from 70-100 and sometimes going down to 30 or even 10
     1 people found this helpful
    Share this post

  3. #3
    I actually fixed it, seems out this was a general problem of my PC. I just restarted the PC and the FPS got back to normal. I know sounds super wierd but it worked. My menu fps is back up to 60 again. The thing is even though I fixed it, I am pretty sure this problem is super common. I even might get it again.
    Share this post

  4. #4
    I'm experiencing the same exact issue except mine has not been resolved at all. The issue started the day of the patch being released. I was playing the night before with no issues at all. Typically my game runs capped at 60fps and 140 uncapped. I generally play on low graphics settings to ensure consistent performance. Following the patch, my game will not go above 25fps. I've done everything imaginable to try fixing this. I currently have a support ticket still open after many attempts by the Ubi support staff to try and troubleshoot the issue. I just did a full reset on my computer (essentially factory reset). The only thing installed on my computer when I tried to run Siege again was Chrome, Steam, and Uplay. The issue remained anyway. It's been extremely frustrating.

    I have an Acer Predator Helios 300 laptop and the specs are:

    i7-7700HQ CPU @ 2.80GHz, 2801 Mhz, 4 Core(s)
    Nvidia GTX 1060M (6GB)
    16GB RAM
    Win 10
    Installed on a 1TB Crucial SSD

    If anyone can offer any other help I'm willing to try just about anything while waiting to see if Ubi can help me fix the problem.
     2 people found this helpful
    Share this post

  5. #5
    Ubi-Redbeard's Avatar Ubisoft Support Staff
    Join Date
    Mar 2017
    Posts
    1,709
    @Learn_x,

    Although your specs might meet the requirements needed from the game, we do not officially support laptops.

    Can you provide me with your case number so I can take a look at what has been discussed so far?
     1 people found this helpful
    Share this post

  6. #6
    Originally Posted by Ubi-Redbeard Go to original post
    @Learn_x,

    Although your specs might meet the requirements needed from the game, we do not officially support laptops.

    Can you provide me with your case number so I can take a look at what has been discussed so far?
    07495455
     1 people found this helpful
    Share this post

  7. #7
    same problem here , but i got it just today , yesterday i played with no problem, played the new map , it ran smooth with no problem , todey i started the game and i had 15 -16 fps max in the menu ,restatrted pc didnt help ,played casula max 20 fps so yea . I alweys played the game on high with no problem 60 fps . On laptop lenovo legion y520, gtx 1050 4g , i5 7gen. 8 gb ram
    Share this post

  8. #8

    FPS Drops after Wind Bastion Uğdate

    It happens the same with me. Yesterday night my game was running smooth and today it run with 20 FPS, today we have a small patch update and after this my game is not the same and i can not play it.
    Share this post

  9. #9
    Yep the same problem, I have GTX1060 6GB and I7-7700HQ, and just before the update the game was running 60FPS really smoothly but after the update, I can get max. 22. Ubisoft please don't tell us that this gonna be the second Tower incident.
     1 people found this helpful
    Share this post

  10. #10

    Same Issue

    Specs
    i5 4670 with no OC
    GTX1080 417.22 Driver
    Memory 16GB

    Sometimes fps drops under 30 after the update.
    Before the update, It didn't happen to me.
    Share this post