Thread: I unlocked relic sets long time ago, and they are suddenly not showing up. | Forums

  1. #1

    I unlocked relic sets long time ago, and they are suddenly not showing up.

    Hi, I recently started a new game, and I realized that the relic sets were not showing up in the inventory.

    Does anyone know the reason?

    Share this post

  2. #2
    Same reason why people cannot reach the Forge: the DRM bugs out.
    Share this post

  3. #3
    Same issue. Never had this problem before(or any problems with the game, really). I wonder if Ubisoft will respond to this at some point.
    Share this post

  4. #4
    Not the first time this has happened. It seems like everytime i want to finally get a start on this game and finish it I run into these stupid friggin DRM bugs.

    This is why places like GOG are so popular. People are fed up with DRM, especially when it breaks games that we have purchased.
     1 people found this helpful
    Share this post

  5. #5
    Jumping in to mention that the issue is still here. I want my relics!
     2 people found this helpful
    Share this post

  6. #6

    relics dissapear

    My relics also dissapear and couldnt mange to find them...
    Share this post

  7. #7

    Relics please or not buying another ubisoft game

    Come on. This really sucks. Can we please get a response to this? Was hoping to play through the game again, but now that I have reinstalled it, nothing. No bonus relics to start out with. Why even bother with this uplay?
    Share this post

  8. #8
    I recently bought the game and I am also having issues with this.
    The free copy of Might and Magic VI that i should have received with the purchase of the Deluxe Edition of Might and Magic X Legacy is not in my library.
    The 3 Club Rewards (Meow Dungeon, Special Relic Set and Sana the Archmage) that I bought/unlock for the game are not appearing in the game.
    Opened a ticket but still no solution.
    Share this post